Flash through Web IDE on Local Server

Hello all,

I’m curious if you can flash through the Web IDE on a local server when the network that’s set up doesn’t have internet access. I haven’t been able to find much around about it or using the web IDE with a local server. Thoughts and comments appreciated!


@greenoutlet, the local cloud server does not run the Web IDE. You can, however, use Spark CLI to flash a core OTA via the local server. :smile:


That would be done using spark flash I’m assuming? The issue with that is I can’t get make to work on windows so I can’t make the stuff in the core-firmware folder and can’t upload :frowning:

@greenoutlet, I am running everything (Spark CLI, local toolchaine) on an old Win 7 x32 laptop and it works very well! There are lots of tutorials for setting that up. :smile:

1 Like

What is this toolchain you speak of?

PS: Just got make working :smile:

@greenoutlet, if you got make to work then you are using the toolchain!! A toolchain is all the make and compile tools needed to compile a set of file, in this case the Spark firmware repo. :smile:

Oh! I’m much more of a hardware guy. All these software systems are way over my head. I thrive on the tutorials. I’m reading a guide, written by yourself actually https://community.spark.io/t/local-toolchain-with-windows-solved/2230, because I can use the “make” command, but can’t get it to finish the make. I get the output

Building core-common-lib
Building file: …/CC3000_Host_Driver/cc3000_common.c
Invoking: ARM GCC C Compiler
mkdir -p obj/CC3000_Host_Driver/
The syntax of the command is incorrect.
make[1]: *** [obj/CC3000_Host_Driver/cc3000_common.o] Error 1
make: *** [check_external_deps] Error 2

just started reading your guide though. It has to do with MKDIR and some other syntax? You just trudged through each repositories make files and eventually got it fixed?

@greenoutlet, if you are using the latest firmware repo, the makefile has changed somewhat. Now, you need to make the changes to the tools.mk file in the build directories for the 3 repos (core-firmware, core-communications-lib and core-common-lib). In tools.mk, just change:

RM = rm -f
RMDIR = rm -f -r
MKDIR = mkdir -p


RM = "C:\Program Files\Git\bin\rm.exe" -f
RMDIR = "C:\Program Files\Git\bin\rm.exe" -f -r
MKDIR = "C:\Program Files\Git\bin\mkdir.exe" -p

Or wherever you have Git for windows installed. :smile:

I’ll post back with results in a minute!

In terms of the make files, in your other guide, it shows

RM = “C:\Program Files (x86)\Git\bin\mkdir.exe” -f
MKDIR = “C:\Program Files (x86)\Git\bin\mkdir.exe” -p

In the make file do I literally change the entry RM to RM = RM = “C:\Program Files (x86)\Git\bin\mkdir.exe” -f
such as




$(RM = “C:\Program Files (x86)\Git\bin\mkdir.exe” -f) $(ALLOBJ) $(ALLDEPS) $(TARGETDIR)$(TARGET).elf $(TARGETDIR)$(TARGET).bin $(TARGETDIR)$(TARGET).hex $(TARGETDIR)$(TARGET).map

EDIT: Looking at this tools.mk file, it looks like it calls on DFU-Util. Do I need DFU-Util to be callable in CMD?

@greenoutlet, get the latest firmware and read my previous post (above). My old instructions applied to older firmware but changes were made to the way the makefile works so you ONLY change the tools.mk file. :smile:


You’re a gentleman and a saint Mr. Peekay123


I’m still getting that same initial error :confused:

I tried including the Git directory in my path variables to see if it would help, but then I think it started to use bash to try and execute make (if that is even possible, it gave me the error that bash was giving me when I tried make in there)