Flash "success"

Quick one: if you don’t see “success” in the console (just device came online) can you assume the flashing was NOT successful?

You can expose a software version number as a Particle.variable() and be absolutely sure.


Thank you! Sorted!

Just as side note, even when you get the “success” event in console, the firmware might still not stick (e.g. due some error after the sucessful binary upload, but failure in the flash transfer which happens after the device went offline).

In addition to explicitly exposing some version indicator in your code, a dedicated “spark/device/app-hash” even created by the system would signal an actual change to the application firmware.

Hello ScruffR

I am using Particle VS workbench to compile and upload the code to the Xenon that is connected via the usb port
The code is able to compile FINE but Flash application command fails, What usb module is the error code referring to while flashing or IS flashing different from upload? as I was not able to find upload in the command pallete

That message about not finding usb refers to CLI which is used to flash the firmware.
It doesn’t have anything to do with the firmware itself and hence you won’t find usb in your project.

You may need to update CLI.

Thanks I did update the CLI and it is running image
I may have found the solution. I notice you posted on the post that

SO the project was created by the freelancer in his workbench environment and he simply send me all the project files. SO All I have to do is create a new project first and copy the dot workspace in the new project Right? I am not sure about the exact steps. Perhaps there is a simple way to asking him for exporting his workbench preference file and then I can import that preference file. That way we have the same work environment.

The post you found there is a bit outdated.
There now is a project import feature that adds the required files for Particle Workbench


See also


Ok, I did Import Project and looks like it is unable to find the Project Properties file that is present in the selected folder.
And when I Click on Open and point to the project.properties No change is noticed on the screen
So I tried to follow the instruction here

I am also unable toinstall VISX It is asking for dot visx file that I must create first to install

What VISX extension do you want to install?
You already have the latest Workbench extension(s) installed.
The .vscode files are already present in your projects too, but since you have multiple project.properties files inside your workspace you’ll need to select the project you intend to work on.

What change do you expect to see?

It is installed workbench core extensions However even if I open the project properties folder I am unable to make the red tick go away

So I open property project and it still has that red tick, how do I get the red tick to go away?
Why do I care about the red tick so much if somebody wants to know? Red is an indication of warning in Workbench. It has been an issue in the past Workbench Visual Studio Code, cannot find the project.properties I guess there needs to be some way to initialize the existing project once it is imported into the workbench using particle:import project

What red tick?
Do you mean this image

That’s meant to be there and shouldn’t go away - it’s an icon that denotes what type of file this is :wink:

:grin: Particle.io sure had me worried for nothing.:smile: