Fixing a bad key (fast light blue pulses with intermittent fast red)

I’ve been gradually working my way through the half dozen nested tutorials from all over the place to fix this problem (which I don’t believe I caused, as it happened just starting the core up without recent flashing or changing of anything) and I’ve run into a problem that I don’t see addressed. I’m on windows 7.

I installed node, cli, dfu-util 0.8, and the driver via ziadig, only ignoring the tutorial to add dfu-util to the global command line commands because it’s for windows xp and I was just absolutely tired of following nested, third party tutorials by then… so I’m running this command from the folder where dfu-util is located. I connected the photon via USB in serial mode, read the device id, and then according to https://docs.particle.io/support/troubleshooting/key-management/core/ , running “particle keys doctor myDeviceId”, the command runs and complains about openssl not being recognized as an internal or external command. I don’t think it’s possible that openssl isn’t on this computer at least in some form, but what can I do for this to be accessible via command line to finally fix this problem.

I’ve also tried downloading the public key from here to flash it https://s3.amazonaws.com/spark-website/cloud_public.der , but the site loads as nothing and cannot be saved at least in firefox… so I have no cloud_public,der to write directly with the dfu utility ( dfu-util -d 1d50:607f -a 1 -s 0x00001000 -D cloud_public.der , as found here https://docs.particle.io/support/troubleshooting/troubleshooting-tools/core/ )

And if my frustration wasn’t clear… please consolidate some of this tutorial information or maybe repackage some of the install content or something. I understand the software and dependencies may be complex, but it really shouldn’t be this complicated to find out how to fix this seemingly common (at least from the length of the thread) problem. I shouldn’t have to click a tutorial inside of a tutorial to install all of the software just to follow entirely different command line directions to try and solve my problem. If there is some kind of global tutorial… maybe there just needs to be better pointers to it.

Ideas on what form of openssl I need to be installed to be able to generate a key using the particle cli?

I’ll just throw this out here in no particular order:
A guide for installing the CLI (that has become sort of the standard): it has worked for me and many others, and should include the openSSL you’re looking for.
It could be that it’s installed but not in your PATH. You should be able to access that through the control panel -> system -> advanced system settings -> environment variables. Better yet, Google for it, since there are ton of guides out there already that can explain the process better than I ever will.

As for the .der file, it downloaded just fine for me (Opera, windows 10). I’ve zipped it up for you, and you should be able to download it [here][1] (at the time of writing)

That’s hard to do because there are so many different configurations of hard/software out there, that makes it almost impossible to create a tutorial for everything. There’s a (community made) installer for windows for most of the software:

That’s to keep it modular so it’s applicable to multiple setups, rather than writing new tutorials for every possible configuration out there. At least, that’s what I like to make of it.

Give some of the above a try, and let us know if you need further assistance.
[1]: http://jordymoors.nl/particle/cloud_public.zip

The zip works as a key and I uploaded it using the DFU utility two ways… neither worked (one was the mentioned input, one was basically the same with no switches) and each produced slightly different results - using the switches also reset it connecting to wifi until configured.

Now though, I go to setup the core in the app and it hangs on claiming ownership and eventually errors out - I can’t use the CLI setup wizard because the computer is on wired internet, but setting the wifi information manually results in about the same non-working results. Claiming in the CLI or the web IDE just throws a generic server error… so I’ll give it a few hours and try again. I had removed the particle from my account prior to trying to set it up again.

I figure I’ll wait rather than try to install openssl because my node.js is the 64 bit version (what their site directed me to initially), and I need to get perl to compile the x64 code since they don’t distribute binaries (which I suppose does make sense)… and I’m sort of sick of downloading extra stuff I’ll use once for a bit. A search of the harddrive shows openssl usage stuff in a lot of applications, but no installation of it.

My complaint about the tutorials was that the ones I were directed to were all over the place… modular is fine, but every new site you are sent to is another chance to be out of date, or a broken link, or otherwise untested with the current set. It also feels extremely hacked together - having them in one centralized place (or direct links from one place) from the particle documentation would make them look somewhat more official and dramatically increase the number of people trying exactly those steps out - which means they’re much more likely to uncover any problems or updates that such a tutorial would need.

Something else that I’d really appreciate is a ‘restore factory defaults’ option in the phone app… that’s really all I’m trying to do and it’s quite obtuse to install a whole development toolchain and then run a dozen console commands to reset it to the settings it shipped with.

Waiting for the server to sort out claiming didn’t do anything… so today i got SSL installed, put everything into environmental variables (which somehow removed node from it, so i had to reinstall that…) and ran the keys doctor command from the CLI after reading the ID in serial mode.

Rebooted and breathing cyan, totally fixed.

Now why it took half a dozen tutorials and something like 8 installations to do this is beyond me, but I am glad that it’s fixed. Replacing the internal keys with the downloaded ones didn’t do anything useful, but whatever the keys doctor command does did the trick, then I just claimed from the CLI with device add.