Firmware version detection


#1

Continuing the discussion from Particle Tools Changelog:

Is there also a fix in the pipeline to have the Electons “On the device:” info refresh without the need to OTA flash and clear the cache?


#2

This information refreshes when a device sends a new describe message. Usually you can force the update by flashing something new to the device. There is an edge case where we’re unable to identify what’s on the device and we leave the previously detected version in the device document. We could add an “unknown version” feature where every describe update would be reflected.


#3

The point is, that OTA updates for Electrons might consume more data then desirable for just a status update/describe message. Could maybe the SIGNAL (previously IDENTIFY DEVICE) be used to trigger the device to send a describe message?

Another option might be to allow a “forced” OTA update with “apparently” incompatible version.
When I know I have the correct system version on the device I don’t want to be forced to first flash old version for the status update and then again the actually desired version (unnecessary data consumption).
Give me a warning and a PROCEEDE ANYWAY just as done for the general OTA.


#4

I’m having this same issue where my build IDE shows the electron with version 0.4.9 but the CLI shows 0.5.3 after particle identify. I have tried clearing the cache and flashed new code to the board OTA but it still shows up as 0.4.9. If I try to flash with version 0.5.3 firmware I get the incorrect version message and no option to flash. Can you point out if I’m missing something or should the IDE be updating the version after I flash using the “on the board” version even though it’s wrong?


#5

exactly that, but since 0.4.9 doesn’t exist for the Electron you’d need to build for 0.4.8 and need to flash OTA.
After that you might need to repeat the clear cache stuff.


#6

Thanks for the quick reply. I just tried flashing again compiling for 0.4.8 and got the same result, IDE still shows version on board is 0.4.9. I have been compiling for 0.5.3 and flashing over serial and everything seems to be working so I’m not sure if it’s just an issue with the IDE or if it will correct itself in time. Either way, my electron is working as expected. If you have any further advice I’m open to suggestions but I don’t think it’s causing any problems as of right now.


#7

It is only an IDE bug and should not impact your device - you just won’t be able to OTA flash more recent target apps via Build.

Are you sure your 0.4.8 firmware got properly flashed OTA from Build?
Maybe put your device into Safe Mode first and then flash via Build (e.g. a simple Blink-A_LED sketch)

You could also try a different browser or incognito mode - or even a different machine.


#8

Removing the electron and reclaiming solved my problem.