Error using library with Electron but not using photon as target device

Hi All,

I saw on the particle forums a post by ScruffR saying that photon shields mostly also work with the electron. My project uses a photon IMU shield with the ‘SparkFunLSM9DS1’ library, however I am having an issue using this library with the particle electron. The library works perfectly with the photon as a build target (maybe build target isn’t the right term - I mean with the photon selected in the webIDE). However when I select the electron as a build target I get an error and my code doesn’t verify. The image shows what I see.

I don’t understand what is causing this error. Is it an I2C vs SPI issue, something to do with clashing libraries or is this library just not configured for an electron? I tried to fix it by changing the library on github but that made no difference.

If anyone could help me I would be incredibly appreciative.


Make sure your Electron is running system firmware 0.6.0 or later. If it’s running an earlier system firmware version, many libraries will not work properly and you’ll get that completely non-obvious error.


Hi Rikkas7,

Thanks so much for your answer, that solved the problem instantly! The support from particle is really good I think.