Error: Invalid dfuse address: 0x08005000:leave [SOLVED]

I ran make all went well. Now i am trying to flash the Spark Core. acording to the readme file it says
to do:

dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave -D core-firmware.bin

yet, i get the following error.
Error: Invalid dfuse address: 0x08005000:leave

Below you can see that i have verified the other steps as well.

C:\Z\core-firmware\build>dfu-util -l
dfu-util 0.6

Copyright 2005-2008 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2012 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY

Found DFU: [1d50:607f] devnum=0, cfg=1, intf=0, alt=0, name="@Internal Flash /0x08000000/20001Ka,1
Found DFU: [1d50:607f] devnum=0, cfg=1, intf=0, alt=1, name="@SPI Flash : SST25x/0x00000000/512*04Kg

C:\Z\core-firmware\build>dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave -D core-firmware.bin
Error: Invalid dfuse address: 0x08005000:leave



You can either update to a more recent release of dfu-util (0.7), or juste remove the “:leave”.
As far as I understood, the “:leave” is only there to do an automatic reset. So, if you stick to dfu-util-0.6 you can either reset manually once it is done, or give another option doing the same in this version (something like “–reset”? Not sure).


I will try to remove the :leave. The only reason why i am not using 0.7 is that there are no .exe files in the download. Only the 0.6 had it. I have no idea why.

I found it now.All is well

Thanks for the help, and by the way removing the :leave did work.

1 Like

This also worked for me. I replaced :leave with -e
I was also was not using dfu utility 0.7