Error installing particle-cli on Mac ./lib missing during NPM

I’m kind of stuck. I haven’t needed to go USB to the spark till now and I have tried 2PCs and now a Mac, none successfully install particle-cli. This is the most recent Mac error, I tried sudo and non sudo. Ideas?

Josephs-iMac:~ JosephSlawsky$ sudo npm install -g particle-cli
Error: Cannot find module './lib’
at Function.Module._resolveFilename (module.js:337:15)
at Function.Module._load (module.js:287:25)
at Module.require (module.js:366:17)
at require (module.js:385:17)
at Object. (/usr/local/lib/node_modules/npm/node_modules/request/node_modules/hawk/index.js:1:80)
at Module._compile (module.js:425:26)
at Object.Module._extensions…js (module.js:432:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:311:12)
at Module.require (module.js:366:17)
at require (module.js:385:17)
npm ERR! Darwin 14.5.0
npm ERR! argv “/usr/local/bin/node” “/usr/local/bin/npm” “install” “-g” "particle-cli"
npm ERR! node v5.0.0
npm ERR! npm v3.3.6

npm ERR! Cannot find module './lib’
npm ERR!
npm ERR! If you need help, you may report this error at:
npm ERR!
Josephs-iMac:~ JosephSlawsky$