Started getting error output on any particle cli command

On Mac, my particle commands (any of them, including just ‘particle’) now return this before successfully completing:

Error loading command /usr/local/lib/node_modules/particle-cli/commands/CloudCommands.js Error: Cannot find module '/usr/local/lib/node_modules/particle-cli/node_modules/serialport/build/serialport/v1.7.4/Release/node-v47-darwin-x64/serialport.node’
Error loading command /usr/local/lib/node_modules/particle-cli/commands/SerialCommand.js Error: Cannot find module ‘/usr/local/lib/node_modules/particle-cli/node_modules/serialport/build/serialport/v1.7.4/Release/node-v47-darwin-x64/serialport.node’

Any suggestions?

Thanks

Can you do a npm uninstall -g particle-cli and npm install -g particle-cli again? Seems like an installation issue

Thanks. I think I had forgotten that I had upgraded to node 5.0.0 and it appears there is a conflict. I downgraded to node 4.2.2 and reinstalled particle and it seems fine.

1 Like

Hi,
I’m also facing this issue on node v5.5.0. I tried to uninstall and re-install particle-cli but it still doesn’t work. I get the same exact error message from the first post.

Fixed! I just had to install the node serialport library (npm install serialport), remove particle-cli, then re-install.