Error in sockets.h?


#1

Hey all, I grabbed a 3.2" tft from adafruit and tried using the Adafruit_HX8357 library on build.particle.io.

However, when I compile for Argon I get the following errors. I am using the example code which compiles when I point it to a photon. Any idea if this is something I can fix easily?


#2

You should use the Adafruit_HX8357_RK library instead. It has been tested with mesh devices.

https://docs.particle.io/community/feather/#adafruit-tft-featherwing-3-5-quot-480x320-touchscreen


#3

I think the reason for that stems from the bundled SdFat library that didn’t support mesh devices. I’m going to reupload the library with an updated reference to the new SdFat version.


Done!
@calebatch, can you please try out “my” library Adafruit_HX8357 v0.9.8 again and see whether the errors have gone?
Thanks


#4

Trying to compile with Adafruit_mfGFX.h and Adafruit_HX8357.h. I am getting an error that Particle Server has failed to process the request on time.

Will keep trying! Just verified, thanks!


#5

Are the RK libraries built by Particle? Would be nice to have the libraries on build.Particle.io have icons for what they have been verified to work on


#6

Yup, I see some unusual latency with online building too. I also see that despite the updated reference to the new SdFat version my builds still seem to use the old version which still produces the errors. Somthing is fishy here.

I think I have to remove the secondary library references entirely and just add a comment in the respective examples to manually import the correct libraries :pensive:


Update:
Solved, now 0.9.8 builds just fine.


#7

Dang, well hmm, why not just make mesh a separate library so it doesn’t mess up others who are using your library?


#8

That’s not an option.
Mesh is a platform, not a library.