Error: connect ETIMEDOUT 52.20.98.88:443 when running 'particle list'

➜  Downloads particle list
Error { [Error: connect ETIMEDOUT 52.20.98.88:443]
  code: 'ETIMEDOUT',
  errno: 'ETIMEDOUT',
  syscall: 'connect',
  address: '52.20.98.88',
  port: 443 }

I get the same error message even using VPN.

What OS are you on and what version of the CLI do you have?

Mac OSX EI Captitan 10.11.5
Particle 1.14.2

Are you able to visit https://api.particle.io/v1 in your browser?

{
  "ok": false,
  "error": "Not Found",
  "device_name": "hoosier hamster hamster normal ferret"
}

Seems ok. Are you behind a proxy? Can you try particle list again?

That IP adress is clearly not the :particle: :cloud: :slight_smile:

➜  ~ particle list
Error { [Error: connect ETIMEDOUT 52.20.98.88:443]
  code: 'ETIMEDOUT',
  errno: 'ETIMEDOUT',
  syscall: 'connect',
  address: '52.20.98.88',
  port: 443 }

The result is the same with or without a proxy or VPN.

I’m not sure what’s wrong with your CLI configuration. Can you show the output for particle config identify?

You can do a npm uninstall -g particle-cli followed by a npm install -g particle-cli to see if that clears the issue.

➜  ~ particle config identify
Current profile: particle
Using API: https://api.particle.io
Access token: 

Okay. I will try to uninstall and reinstall.

The same after uninstalling and reinstalling.

That IP address belongs to Nanit, which is apparently an IP connected baby camera/monitor company. Are you developing or using a Nanit product that could have installed a proxy or routing rule? Maybe they use CoAP too?

In a terminal shell, what happens when you type nslookup api.particle.io?

I see two Amazon AWS hosts that can answer to that name here in the US.

1 Like
➜  ~ nslookup api.particle.io
;; Got SERVFAIL reply from 222.172.200.68, trying next server
;; Got SERVFAIL reply from 222.172.200.68, trying next server
Server:		61.166.150.123
Address:	61.166.150.123#53

Non-authoritative answer:
api.particle.io	canonical name = particle-api.nodes.spark.io.
particle-api.nodes.spark.io	canonical name = prod-particle-elb-1247621827.us-east-1.elb.amazonaws.com.
Name:	prod-particle-elb-1247621827.us-east-1.elb.amazonaws.com
Address: 52.4.38.56
Name:	prod-particle-elb-1247621827.us-east-1.elb.amazonaws.com
Address: 52.205.55.201

BTW, I am not using any Nanit product.

I looks like your first DNS server did not know how to find api.particle.io and so punted to a secondary server. I think that is very likely related to your problem.

Can you try setting your DNS server to a known good one, like google’s at 8.8.8.8 and try again?

1 Like