Electron won't connect to cloud on asset tracker

I’m experiencing a strange problem with my Electron. In short, the Electron will happily connect to the cloud when not connected to the asset tracker, however as soon as its plugged onto the asset tracker it goes into the rapid cyan flash then short red flashing sequence, repeat forever. It never goes into the breathing cyan.

I’m using the standard asset tracker library for the GPS tracker. I’ve tried various things including; updating the firmware to 0.5.2, local cloud key update, local device key update, and downgrading the firmware to 0.4.2. None has made any difference.

It did work fine for the first few days. Only recently has i started behaving strangely like this and I am stumped! I think that something has gone wrong with the asset tracker shield. Is there anyway of testing this?

Huh? I thought the earliest Electron firmware was 0.4.8.

Could it be a power issue? Have you got the LiPo attached and a reliable DC source?
If the supply current is a bit low the connect won’t succeede causing such cycle.

Or - excuse the impertinent question, but we had such a case :flushed: - could it be that you inserted the Electron back to front?

Sorry, that was a typo, i meant 0.4.8.

Thanks for the advice, i will try that now. I’m using a fully charged Lipo on the Electron but will also try a separate power source for the AT shield.

I tried a separate 9V power source direct to the AT board, and also a Lipo into the Electron and i’m getting the same result.

Its connected the correct way round yes. Would it damage the AT if the Electron was inserted the wrong way?

I’ve seen the GPS initial acquire interfere connecting to the cloud with 2G. It might be a cellular signal strength issue, not a 2G/3G issue. In any case, you can test this by flashing non-GPS firmware to the Electron like Tinker and seeing if you get to breathing cyan while in the asset tracker. If that works you can delay starting up the GPS until you connect to the cloud, use the coin cell battery to keep the initial GPS state, or use an external GPS antenna.

1 Like

I did try a basic blink application that flashes D7 every second and got exactly the same result.

It just does not want to connect to the particle cloud when on the board.

Edit: Never mind, I just realized that was ScruffR’s picture, not yours.

One thing I did try was to run the script in SEMI_AUTOMATIC mode to prevent it connecting to the cloud. This actually does work and it finds a GPS fix and reads the accelerometer just fine.

However when i run Particle.connect() it crashes and goes into the never ending rapid cyan-red flashing sequence.

Anything else I can try doing?