Electron update to 1.0.0 (from 0.7.0) causes SOS hard fault

electron
Tags: #<Tag:0x00007f038f5e4b30>

#1

I have a working application on a Electron with 0.7.0.
I have tried to update to 1.0.0.
After update, electron boots straight into SOS Hard fault mode (1 blink between SOS pattern). It even does not do the first green blink to try to connect to cellular network.
The compilation (local) and Flash (dfu mode) finishes without errors, but when the Electron boots it crashes immediatelly.
I have tried clean compilation, removed target folder, …
If I recompile same source against 0.7.0 and flash it, the Electron boots correctly (and Device OS is still on 1.0.0)

Using:
-Workbench 1.0.0-alpha.7
-particle-cli 1.37.0
-3rd party sim

I have take care about using PRIVATE or PUBLIC for Particle.publish() (well in reality I use PublishQueueAsyncRK library)

Any clues about what to check?


#2

That’s probably due to an already known issue that your code is probably instantiating an object which relies on the presence of another not yet instantiated object.

My guess is on the PublishQueueAsync object using the not ready Particle object.
But Rick has already updated his library to feature a setup() function to be called in void setup() - look at the new examples.


#3

Solved. It was exactly because of that. Thx ScruffR