Electron not registering to cloud and draining SIM credit

Any one having problems connecting?
Mine is stuck with a rapid blinking cyan light, never gets to ‘breathing’ has 3 flashes of sign strength, and the SIM has so far consumed 0.06MB of data according to the dashboard.

Sorry to hear that @wdj — the fact that you have SIM usage sounds like the device is attempting to handshake with the cloud and is failing. Try putting the Electron in DFU mode, then run particle keys server. If that doesn’t fix it you should also try (in DFU mode) particle keys doctor.

If neither of those work, please go to support.particle.io and submit a question in the form. Include the ICCID number from your SIM card as well as your device ID. You can get both with particle identify while the Electron is plugged in to your computer with USB and in listening mode (hold MODE for 3 seconds until the LED blinks blue).

Hope that helps!

Hi Zachary,

Tried all that, and does not help, same problem, and burning up SIM credit.
Have emailed device details via the support form.
I vaguely remember having similar problems with the spark core when I first got it too.

It’s awesome by the way… and I sure it’s an easy fix for you.


I know this is probably a dead thread, but did you ever find a fix for this? I’m having the exact same issues.

It’s constantly rapidly blinking cyan and burning up my data. I have also tried the above suggested commands to fix the keys.


@benstill824 did the electron ever connect successfully (breathing cyan) before?