Electron: Flash Unsuccessful

Seems I have used up my flashes for the day. Now the web IDE always takes longer than usual, then complains “flash unsuccessful,” leaving my electron frantically flashing the green led for a while, then running the program I last successfully loaded a while ago. Seems it only works a couple hours a day.

Isn’t the engineering term for this “Phase of the Moon?”

Should I make a stand to hold the antenna up in the air?

Hmm. Worked just now. Been stuck for about an hour.

If your electron is flashing green that means it is not connected to the cellular network. When you aren’t flashing, is it consistently connected (breathing cyan) or does it disconnect when you try to flash?

Is it possible your electron is only connected to the network sporadically?

Also, are you using the particle SIM card or a 3rd party SIM?

When you say “used up” you indicate that you had changed the running code, and one of these changes may now be interfering with your ability to OTA update.
Often the reason for some misbehaviour of the devices is much closer than the moon - or even the clouds :wink:

2 Likes

Could be a weak cellular connection. Sometimes I’ve found the antenna laying next to a pen or something.

Often it’s running the program, I flash the blue led to indicate the program is running, then I edit the source, but when I go to flash, it starts flashing green. Wondering if I can use USB programming on the mac. Usually happens when I think I’ve finally found the program mistake.

I also have to use the particle cloud from James’ Macintosh since my PC won’t log into build.particle.io since Monday afternoon. When I click login, it sits for a long time then says, “Server error: contact support.particle.io.” They’re puzzling over this. I was going to download the local ide, but that requires you to log in…

Well, after 5 or 6 edit-flash-(curse) cycles, it just stops flashing, and won’t flash for sometimes a few hours. As a developer used to spending all day, this is pretty frustrating.

I have no issue running dozends of consecutive reflash cycles - although I tend to not reflash on mere minor changes to a project.

But when you have the device next to you on the table, I’d rather go with wired updates to avoid using up the cellular data quota.

Do you mean you need to register for the Alpha preview or actually login to your Particle account after you’ve installed Workbench in order to access your devices via the cloud?
What are the reservations against either of these?

1 Like

@Tentoes even if a firmware OTA update has a problem, it would almost never cause the cellular modem itself to disconnect. I assume when you say “flashing” you mean “flashing green” like you mentioned before? “flashing cyan” would imply something very different so it’s a necessary distinction.

I would recommend getting a sense of the signal strength the device is getting. Try running this code and seeing what these numbers are:

// at the top of your program
bool is_first_time = true;

// in loop()
if (Cellular.ready() && Particle.connected() && is_first_time) {
     CellularSignal  sig = Cellular.RSSI();
     char signal[64];
     snprintf(signal, sizeof(signal), "Cellular signal RSSI: %d, signal quality: %d", sig.rssi, sig.qual);
     Serial.printlnf(signal);     // if you can check via usb serial
     Particle.publish(signal);     // to send to particle console via cloud (you need the console already open to see this
     is_first_time = false;
}

I echo the above sentiment that generally flashing via DFU mode using the Particle CLI is going to be easier and allow you to have more flexibility in a local development environment (which I also recommend, if only for better library management).

Oh, I was going to ask if there was a way for electron firmware to tell if cellular was connected.

I have to learn how to flash with USB cable.

On yet-another-macintosh now. This one dedicated to the purpose.

That my stupid PC always gets “ERROR: Please contact support.particle.io” when I log into the build.particle.io.

I’m now on a macintosh that’s dedicated to this project.

Particle Workbench doesn’t require you to be logged in at build.particle.io

I have the windows installer for the particle workbench. It installs and works nicely, until I close it. Can’t find the installed program or shortcuts anywhere.So I’ve been using the cloud IDE on another computer. I saw the new one, and thought I’d give it a try, but when I hit the download link, it sends me to the blue particle login page that won’t work on this computer for unknown reason.

So, I’ve been using a coworker’s macintosh. The web IDE seems to work, but after a few edit-flash-curse cycles stops flashing the blooming electron, whose green led is flashing instead of breathing. It will then not be able to do it again for a few hours.

We have just dedicated a macbook to this task so I don’t have to boot my coworker out to work. Of course, last week, this PC was handily running the web ide itself. Haven’t tried and edit-flash-cry cycle with this macbook yet.

Notice, I am using the offending PC to post this.

Are you sure you don’t mean Particel Dev?
Particle Workbench is based on VS Code and on Windows you should find the link at
C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Visual Studio Code
and the program itself at
C:\Program Files\Microsoft VS Code

In Start Menu you should have a tile like this
image

Um. Yes. I seem to have particle dev.

So, to put particle workbench beta, I have to apply for early access and log into my particle account. This gets me to the blue particle login screen which always gets the error contact support.particle.io message after a few minutes, unless I use something besides my windows computer.

But I install particle dev, which takes a long time. It works as long as I never close it. If I close it, I have to install (or find) it again.

This wouldn’t be a hardware problem?

Let’s see. I have the TFT display powered from the 3.3v output. The backlight LED from the +5v output from the USB. The display connected to SPI1, D5, C0 and C1…

I pulled the electron out of the breadboard so nothing is connected to it, and flashed it 3 times without a hitch. Shall we try for four? Fourth time, no problem.

Plugged it back in and successfully flashed it twice. Maybe not a hardware problem.