Electron connection problems

I am a professor and my students and me bought particle electron devices but we are having some troubles trying to connect them to the cloud they are not steady I mean they are not showing stability, sometimes recognize the ping that is in the IDE and sometimes not. Any help? We are working with the original chip and with 3rd party chip and same results.

Are you seeing this with the stock Tinker firmare or custom code?
How good is signal quality at your place inside?

1 Like

Custom code in IDE OTA

Your code might be interfering with some of the processes. If you could share that, we could take a look.
Are the devices consistent when running the default Tinker?


I changed the System firmware target to Deafult (0.6.0) and it worked after one hour or more trying to flash.

My device firmware is 0.6.0

But I noticed that is not stable.

Again, the code running on the device might interfere, and without seeing that code, there’s not much we can say.
Does it flash properly when running Tinker and/or in Safe Mode?

1 Like
int ledPin = D7;

int durations[]={200,200,200,600,600,600,200,200,200};
int gaps[]={200,200,600,200,200,600,200,200,600};

void setup() {


void loop() {
    for(int i=0; i<9; i++)

void flash(int duration, int gap)

I tryed to flash it again and I could not.

My System firmware target to Deafult (0.6.0) and My device firmware is 0.6.0

Should I change my device firmware?

PS. My electron is fine is breathing cyan

it says: The request seems to take longer than usual. Please be patient…

and flash unsuccesuful

Electron blynking Cyan = OK
Firmware syste= 0.6.0
Device firmware = 0.6.0

It says: The request seems to take longer than usual. Please be patient…
Flash unsuccessful.

Inestability: sometimes flashes good and few minutes later will not flash OTA

Any help?

Your code is full of delays which will be getting in the way, you should use millis() timers instead.
As I understand it Electrons only flash OTA if part of a “product” due to the data usage, development and experimental code should be flashed over USB instead.


It was solved with Particle.keepAlive(120) in void setup…(I am using 3rd party SIM)