Electron Asset Tracker v2 fails to lock to GPS

Hi Everyone,

I recently got an Electron Asset Tracker v2 and was playing with it. The accelerometer example project is working for me but unfortunately, the GPS example is not working. It looks like the GPS is not locking and hence no data is coming out.

I have seen many similar posts on Asset Tracker v1 but nothing specifically on Electron Asset Tracker v2, hence posting.

Thanks,
Rahul

Are you trying to get a fix inside your house?

Yes,

I even went in the open area, but it didn’t help.

I am also seeing issues with the cellular tower. But it catches the network it left for couple of minutes.

Thanks,
Rahul

How long have you left the device outside to get a fix?
Cold starting GPS is slow as it needs to download the satellite positions via a very low bandwith channel.
And due to the low power signal from the satellites you won’t get a good fix inside easily.

But I think that’s what was also said in the v1 threads and the system hasn’t changed since.

Cellular has magnitudes more power than GPS, so that’s not a valid indicator.

Usually, the first GPS lock takes some time and it requires a good view of the sky from all directions to speed up the initial lock.

As long as you have a battery attached the GPS should remember the first lock and make future locks happen much quicker, like in under 1 min. That’s how it works for me using an older not as good Adafruit Ultimate GPS receiver. I can get a fix in my house after not having the unit turned on for months in less than 1 min but the initial lock took some time.

Hi Scruff,

It worked once for me when I left the unit in my terrace for 15 mins, it worked fine after I came inside my room. But now once again same symptoms.

Guess I should get an active antenna.

Thanks,
Rahul

I mentioned this in my other thread last week, but I can’t even get the Asset Tracker v2 to “use” the patch antenna. I have an external antenna and the fix works fine with that plugged in, but if I toggle the U-Blox config to use the patch antenna, the signal quality is exactly the same, which indicates the RF Switch is still actually utilizing the external antenna (and when I unplug the antenna the signal immediately goes dead, which further confirms it’s still trying to use the external antenna). I have yet to get an answer for how to “correctly” switch to the patch antenna.

Another thing I noticed is the Asset Tracker v2 seems to be more prone to interfering with the Electron’s cell antenna (the Taoglas one included with the Electron). I’m not sure if this is due to the smaller enclosure, the new patch antenna, or the new Asset Tracker shield (or some combination of them). If I lift the cell antenna outside of the enclosure, even a half inch outside of the enclosure, the signal is much stronger. With the cell antenna inside the enclosure I get frequent cell dropouts unless I’m in a location with good view of the sky (outdoors).

Mike

Did you disconnect the battery between these test? If the GPS unit loses power you will have to start the GPS lock process all over from a Cold start which takes longer.