Did anyone successfully do an OTA upgrade to Electron 0.8.0RC4?

Did anyone successfully do an OTA upgrade to 0.8.0RC4?
I am trying to upgrade some electrons (part of a product) to firmware 0.8.4RC4
So far, the devices are ‘dead’ afterwards and require a USB flash of firmware and code.
Upgrading to 0.8.0RC2 and RC3 via Cell connection was not a problem. Just RC4 fails repeatedly.
Tried upgrading from 0.7.0 und 0.8.0RC2

Any ideas what’s wrong?


I did more testing with different electrons. All show the same issues after an OTA upgrade to 0.8.0RC4
Could it be that there is an issue with the particle console where the Device OS does not get automatically updated with 0.8.0RC4 ??

Upgrade to 0.8.0-rc.4 by flashing product firmware requiring 0.8.0-rc.4 and letting safe mode healer upgrade the Electron should work. Several customers have done so but I haven’t tried it myself.

  • What system version was on the devices before upgrade?
  • What is the LED status of the device in this state? Is it in safe mode (breathing magenta)?
  • Have you tried manually updating the system firmware OTA to 0.8.0-rc.4?

If you’ve had this happen within the last few days, the best thing to do is submit a suppor ticket with the information above and what device ID has experienced the problem. It has the be within the last few days as the logs don’t go back that far.

Here is what I have done:
Starting point are several electrons running my application. Firmware Versions are 0.7.0, 0.8.0RC2, 0.8.0RC3
All these electrons have been added to a product (because OTA Upgrade via WebIDE is only possible with same firmware version.)
I now recompile my application (without code changes) but for firmware 0.8.0RC4 via web IDE and download the .bin file
I then create a new “firmware” version in the web console product configuration and upload the .bin file.
Then I assign this “firmware” to one of the devices and select “Lock”.
The OTA upgrade starts immediately, I can see it flashing magenta.
After this step, the device does not boot my application anymore. I don’t remember the exact colors it is flashing, but there is a lot of magenta, I think. I even had one device go totally dark.
I managed to recover a device by updating the firmware to 0.8.0RC4 via dfu-util (system parts 1-3). The correct application version was on the device. So to me it seems, that the OTA upgrade process does not upgrade the system firmware to 0.8.0RC4, just the application code…
The exact same thing happens when starting with 0.70, 080rc2, rc3. Upgrading to any of the version below 080rc4 is working fine, just 080rc4 is causing these problems.
My devices are located somewhere in the field and are not accessible via USB, so it is very important that the Upgrade process works reliably…

Tried it again yesterday:
Downgraded firmware to 0.8.0RC3
Then did on OTA upgrade via Web IDE. Exact same code, just firmware now 0.8.0RC4
After the Upgrade, the device was breathing purple and did not work.
I then flashed just the firmware to 0.8.0RC6 and now it was working fine.
So to me it seems that an OTA upgrade somehow misses the firmware…


To answer the question you posed on this thread, yes I have and it worked properly. I hope you get get your issue resolved.

Thanks, Chip

Same issue with 0.8.0RC8 … The OTA Flash process via Web IDE does not upgrade the system part, just the user code.
So afterwards the Electron comes up flashing green (I’m using a 3rd party SIM). It won’t connect to the Cell network, because the APN is configured in the setup() routine. (system mode semi_automatic).
So there is no chance for it to download the system parts later on without cell connection.
This was working fine before 0.8.0RC4.
So it’s either a bug or particle wants people to use the particle SIMs…

If the APN was set once after power-up the module keeps the setting stored - the only problem is the Particle.keepAlive() that won't be remembered.