OTA Firmware update trouble


As it says I’m having trouble with updating the firmware on an electron OTA. It was version 5.4 and I tried flashing the tinker app with version 6.0, 7.0, and 8 … none worked, it would flash, then reboot into safe mode and stay there, one time I left it in safe mode for over an hour just to check, never left. I manually reset it and it was still version 5.4.

I brought it to my pc and manually updated it to version 7.0, which worked fine. So after manually updating the firmware and loading the tinker app in version 7.0 to it I figured I could changed the target to the newest, 8.0.rc4 and update it … same thing, its stuck on 7.0 now.

I have 4 electrons in total and this is the only one with this issue.

What am I missing?


just to add to it, when I launch the flash update from the web ide it flashes magenta rapidly, then resets, goes white, then green, then cyan and just when I think its good, it starts breathing magenta. doesn’t matter what code I load to it, unless I back the version down to 7.

The process you used was correct, however there was a problem with the safe mode healer service, which is what upgrades the system firmware for devices when needed. That’s why the upgrade did not occur. It has been fixed and if you reset the Electron it should get the update now.

1 Like


I tried an OTA upgrade today as well that failed. I was able to physically update using DFU mode but, I hope the next one goes more smoothly.



What time today? It was just fixed, around 1:30 PM EDT (-0400).

I started the update at 1000 Eastern and gave it until about 1100 before I did it the old fashioned way.



Works perfectly now.

Was this a published issue? Is there a place where I can find alerts about these things?

@ShakerBreaker, refer to OTA update of 0.8.0-rc.4 app on 0.8.0-rc.2 device noting my kit was a Photon.

Reading this ticket I can see that your problem was (probably) one and the same as mine, but I was able so solve using OTA, which is what you want if the kit is in the field.

PS - my troubles were circa 12:30 UTC+10 on 2018-06-07