DFU-UTIL Issues

My Internet Button either flashes red or goes to DFU-Util mode.
I have tried to follow instructions for Windows flashing software to no avail. I cannot seem to get the DFU-UTIL software to run correctly, after spending about three hours trying different methods, why is this so damn hard to do? I also see there is a CLI method but the instructions are not very clear on how to start. Can I use a windows computer to install CLI or is it installed on the photon. How is it installed. The instructions need some clearing up for the non super geeks. For such a line of products these instruction are quite poor. Can someone help to streamline or clarify the instruction for CLI or Windows support for dfu-util re-flashing.
Thanks
Tom

The easiest and first way tor try is putting your device into Safe Mode and reflash it OTA.

Have you tried that and does this change anything?

Giving some more info about the situation preceeding your issue might help to guess the cause of your problem and suggest possible avenues to solve it.

There’s this:
https://docs.particle.io/guide/getting-started/connect/photon/#installing-the-particle-cli
This:
https://docs.particle.io/guide/tools-and-features/cli/photon/
This:


This:

And this very useful one:

This one in particular for DFU:

So I’d say that there are quite some resources available, all of whom I’ve used successfully in the past. That said, if you’ve got any suggestions on how to improve the process, feel free to share.
As to getting it working, I can highly recommend the installer by Mumblepins, which has been really helpful for me in the past.