Device setup library is not compatible with Android SDK 29

Hi there,

We have an android app where we include the device setup module. The app targets Android 10 (API level 29) and when the setup process is launched there are a couple issues with the module:

  1. First issue that leads into app crash when launching setup process (very easy to solve): This module uses as dependency, but it is deprecated and not longer working in SDK 29 (see: and This issue was solved by updating the dependency according to the new version.

  2. Once the first issue solved, one can reach the setup process without any app crash, but after you reach the “DiscoverDeviceActivity” no devices are found. I suspect that the error can be related to the fact that the “WifiConfiguration” class is deprecated and not longer working on API level 29 (see: However, this is a bit difficult to debug if you do not know the code 100%, which should be easier to you to diagnose.

In any case, I see that there are not big releases since 2019. Are you planning to upgrade the device setup module to SDK 29?

I see this a big limitation for apps that include this module and attempts to use API level 29, since the setup will not work. Moreover, according to google, from 2. November 2020, app updates must target Android 10 (API level 29) or higher (see: So this is a big problem for our product since we will not be able to release new changes if this module is not compatible with API 29.

Thanks in advance for your help and I am looking forward to hearing from you soon.


ping @marekparticle and @jensck_particle


Are you planning to upgrade the device setup module to SDK 29?

yes. aim is to have something available in the next few weeks. thanks for your patience :pray::+1:



How is this going? Will you release a new version before Google’s deadline 2. November 2020?

Thanks in advance :slight_smile:



I see new device setup 0.7.0 version is available in JCenter, but I am not able to upgrade in my android project (Even if android suggest upgrading version from io.particle:devicesetup:0.6.3 to io.particle:devicesetup:0.7.0).

I got the following error:
“Failed to resolve: photon-tinker-android:commonui:unspecified
Show in Project Structure dialog
Affected Modules: XX”

Do you have any idea what can be causing this?

Thanks in advance :slight_smile:

hi all :wave:

the v0.7.1 update of the device setup library for android has been published. please confirm you are able to upgrade and things are working as expected.

thanks for your patience :pray:

ah, looks like we hit another publishing bump - we’ve published an update with a fix as v0.7.2 - give that a try and let us know if there are still issues :pray::+1: