Android Device Setup Library Installation Bug

Howdy. I am having trouble installing the device setup library.

I have a brand new installation of Android Studio.

First bug: the documentation says to use io.particle:devicesetup:0.1.3, but that version is no longer listed at

Second bug: I tried installing all of the other versions. They all fail when Gradle syncs. The newest version fails with:

Warning:Module 'com.afollestad:material-dialogs:' depends on one or more Android Libraries but is a jar

Older versions (i.e. 1.4) fail with:

Error:Failed to resolve: com.afollestad:material-dialogs:

Third bug: to even get this far, I had to put the following in my applications gradle file, as per the instructions for material-diaologs:

maven { url "" }

The current device setup lib should be OK even without the jitpack reference, unless the maintainer has messed with his jcenter distribution again… In either case, that lib has become more trouble than it’s worth; I’m going to remove it and do another release. Thanks for the heads up!

Cool, thanks for the quick reply. I’ll give it another try soon.

I am using Android Studio 1.5.1

This issue occurs when I use compile ‘io.particle:devicesetup:0.3.2’ in my modules build.gradle
Error:Failed to resolve: com.afollestad:material-dialogs:

I’m going to be releasing an update to the SDK in the next few days which resolves this permanently by simply removing that library. In the meantime, you can add the repo to your build.gradle as mankyd described.

I followed what mankyd suggested and did get that same warning, but then when ./gradlew assembleDebug from my terminal on Ubuntu I’m not able to compile my app with the setup library. I’m getting:

Module 'com.afollestad:material-dialogs:' depends on one or more Android Libraries but is a jar
:app:prepareDebugDependencies FAILED

My allprojects section of the project level gradle file looks like:

allprojects {
    repositories {
        maven { url "" }

I’m brand new to developing an Android app so it’s quite possible that I just don’t know what I’m doing yet.

1 Like

Hi Jhodapp!

Did you solve this problem already?

I have the same error.

Sorry to hear you were having trouble with this. Updating to the 0.3.1 release of the cloud SDK (and the 0.3.3 release of the device setup lib, if you use that) fixes this issue.