Device doctor fails after flashing

I’m standing here with a device based on P1 that is out at a customers location. The device is blinking single red blinks, then some white. I have seen this before and the solution has been to run the Particle device doctor. The first step of upgrading the firmware goes fine and then this happens:

! System firmware update successfully completed!

Your device should now restart automatically.

Flashing the Device Doctor app

This app allows changing more settings on your device

Put the device in DFU mode
Tap RESET/RST while holding MODE/SETUP until the device blinks yellow.
? Select Continue when ready Continue

Flash success!
The Doctor didn’t complete sucesfully. Could not find serial device. Ensure the Device Doctor app was flashed

Please visit our community forums for help with this error:

And I’m thrown out into the command line. Note the second last line here. It cannot find a Serial device. If I open Serial Monitor, it finds the serial device as it should, but nothing happens on the Serial connection.

If I skip ahead a bit in the Doctor, I can also setup the wifi and I am also capable of Resetting server and device keys, but if I select “Configure IP address” I’ll get thrown out. The same goes for “Clear all data in EEPROM storage”.

I’m stomped. Anyone knows how I get around this?

Let me ping someone that might be able to help, @rickkas7 are you able to assist?

1 Like

Anyone? I really need some help on this one. It’s related to this thread but this behaved a little different in that I couldn’t go through all steps successfully.

It looks like it’s not taking user firmware. This could be a hardware failure or possibly a boot loader issue.

I’d see if you can flash tinker manually or if you get an error like last page not writable, which would indicate a hardware problem.

In DFU mode:

particle flash --usb tinker

If that works, then try in listening mode:

particle serial inspect

To see what system and bootloader parts are present.

1 Like

I have a similar issue. I get through a few steps of device doctor, flashes device doctor app, clears eeprom, then

Okay! New keys in place, your device will not restart.
The Doctor didn’t complete sucesfully. undefined

Please visit our community forums for help with this error:

I can flash Tinker, but the particle app shows it as a photon. I compiled for an electron with 0.7.0 system firmware.

If device doctor doesn’t work, can I assume it is dead for good? Or can it be rescued via serial programming?

I’m thinking it may not be a hardware issue, because now a second electron has the same problem. Well, I’m visiting the forum for help. Any ideas? Aside from fixing the spelling error?

"Okay! New keys in place, your device will not restart.
The Doctor didn’t complete sucesfully. undefined

Please visit our community forums for help with this error:…"

Same problem with a Photon that I bought during the preorder. It’s an oldie getting its first update. But, I’m stuck. As I remember, this is the kind of crap that made me abandon the device years ago.

My experience with Device Doctor is that it fails about 1 out of 3 times. As stated in this thread, it will get to the end and then fail. Normally I do it again and it works, sometimes it takes 2-3 times to make it work with the Photons I’ve used. I’ve tried different cables, USB ports, computers, O/S’s…no difference.

@syrinxtech @BrunoBronosky A neat trick I learned today from @ScruffR - hold down the Setup button for 10 seconds or more (until there’s some really fast Blue flashing) to wipe any Wifi credentials and then try running Device Doctor again. Saved my day!

Thanks @jenschr. I’ve used that trick many times in the past but haven’t tried it after a device doctor fail. I will give it a try the next time it happens.

Oddly enough, I have used device doctor several times lately on my Mac and it hasn’t failed once. All of the previous failures have been with Windows 10.

Yeah. Used to be like that for also - until yesterday :wink:

I often get Particle doctor failures with “undefined”. It is normally because something is using or attempting to use the serial port that the particle creates on the PC, for me this is usually visual Studio with visual micro or Arduino serial agent, this software continually polls serial ports to see they are usable and it seems to mess up the doctor. If I close Visual Studio and Arduino agent plus any programs that might be using serial ports then Particle doctor works.

same problem with three photons…

this is really frustrating, not sure if I should continue considering photon for my projects.

I was never a fan of particle device doctor as it rarely worked for me either.

If this is a keys issue, I’d recommend the manual way:

  • put the device in DFU Mode
  • run particle keys doctor <yourDeviceID>
  • run particle keys server

If it’s not a keys issue there are too many unknown variables to advise more since alleged “same problems” rarely really are :wink: