Default max current draw too low for 2G

After spending 4 weeks with support, this is listed here to help others.

A device based on boron (B5) without a battery, frequently reset while on 2G (requires around 2A). This also failed on the SOM evaluation board. I may have previously had a similar baffling experience with a Boron 2G/3G.

While the B5 data sheet mention that a 2A adapter is needed, it does not seem to mention that Gen 3 devices default come with a powerSourceMaxCurrent set to 950mA. So out of the box 2G is not supported without a charged battery attached, and a B5 default, do not have a charger on board or a battery.

For people who have not worked with 2G before, it would also be misleading to read the power consumption section of the data sheet, as there are no currents listed above 1A.

This fixed it:

    SystemPowerConfiguration conf;
    conf.feature(SystemPowerFeature::DISABLE)
    .powerSourceMaxCurrent(1800)
    .powerSourceMinVoltage(3880);
    System.setPowerConfiguration(conf);
2 Likes

Thanks for sharing this solution with the community!