Creating Library. Fatal Error - No such file or directory [Solved]

Hello all,

I’m working on a new library for a device I’ve created and I’m running into a Fatal Error problem. I’ve gone through many different examples and forum posts, but still can’t find a solution.

In the Spark uber-library-example, their example cpp file has this:

// IMPORTANT: When including a library in a firmware app, a sub dir prefix is needed
// before the particular .h file.
#include "uber-library-example/uber-library-example.h"

I’m trying to add the same include statement in my example file and I get this ERROR.

hover-example.cpp:2:19: fatal error: Hover.h: No such file or directory

^
compilation terminated.
make: *** [hover-example.o] Error 1

I’ve tried #include “Hover.h”, #include “Hover/Hover.h”, #include “hover/Hover.h”, "#include "hover_spark/Hover.h"
I also have the #include “application.h” above it.

My Github link: https://github.com/jonco91/hover_spark

Can anyone please provide some guidance? I’m running in circles.
Thanks in advance,
Jon

Did you import the library to your account on Web IDE?

HI Kenneth,

Yes, I have imported the library onto my account on Web IDE.
I see it under - My Libraries.

Can you show a screenshot of the top of your code + all the files in your App?

All my code can be found here: https://github.com/jonco91/hover_spark

@jonco91,

1.) The name of your library in the spark.json file is Hover.

I tried to change to #include "Hover/Hover.h" and it works.

You should use the all-small-caps for your name in the spark.json file

2.) There are some errors after the Web IDE is able to find the files. You can probably fix it with `#include “application.h” in the respective file

Have fun :wink:

1 Like

@kennethlimcp

That’s just magical.
I resolved all the other issues and will be publishing it soon.

Thanks for your help.
Jon

2 Likes

Hello, I am facinng a similar problem where am trying to import AMQP library to my code from Github. However, it keeps showing a fatal error that No such file/directory found. Please if you can help me in resolving it, I would really appreciate. I am uploading a screenshot of my code,

You should use the exact case for the include

// either it's
#include "SimpleAmqpClient/SimpleAmqpClient.h"
// or
#include "simpleamqpclient/simpleamqpclient.h"