Console: Cannot add firmware, cannot delete Product

I just wanted to try out the new console for the first time.
Immediately I ran into two major problems.
When I try to upload the firmware, I always get the error message
"Bummer! Your firmware could not be created. The platform id in the binary must match the product platform id"
The firmware was compiled and downloaded via the web IDE an can be flashed to the device via dfu-util without problems.
Is there a way to specifically set the platform ID when compiling in the web IDE? Or is it an issue with the new console not handling the Cores properly?

Also, to be sure I did not accidentally specify a different platform when I created the product in the console, I set up another product. Now, I cannot remove this product. This was just a test, but now I have a product in the list I don’t need. Can’t find any ‘Delete Product’ option…

Update : Adding firmware for a ‘Photon’ product works. For a Core it does not.

Thanks for any help,

+1. Same issue for me.
@jeiden Would you have any insight into this?

I did open a support ticket with particle and just got an update: They think they have found the issue and implemented a fix.
I just tried uploading an image for the core and it seems to be working fine now!

1 Like