Console and particle variable

Hi I’m not able to see my variable in Console so for this reason I modifiy a simple code.
There is someone so kind to explain to me the reason. Network problems? or?
Thanks Valentino
Here my code :

 int led1 = D7; // Instead of writing D0 over and over again, we'll write led1
// You'll need to wire an LED to this one to see it blink.

int led2 = D6; // Instead of writing D7 over and over again, we'll write led2

double prova=2.45;
void setup() {
 Particle.variable("Test:",prova);
  Serial.print(9600);
  pinMode(led1, OUTPUT);
  pinMode(led2, OUTPUT);
}

void loop() {
  // To blink the LED, first we'll turn it on...
  digitalWrite(led1, HIGH);
  digitalWrite(led2, HIGH);
  Serial.println(prova,2);

  // We'll leave it on for 1 second...
  delay(1000);

  // Then we'll turn it off...
  digitalWrite(led1, LOW);
  digitalWrite(led2, LOW);

  // Wait 1 second...
  delay(1000);

  // And repeat!
}

Ciao Tino, I would remove the : (colon, two points) at the end of the variable name Test, so that line would look like:

Particle.variable(“Test”,prova);

Does that fix it?
Gustavo.

Hi Gustavo
first thanks for the answer.I modify but same no variable to see on console.
I wrote to the community because this morning at 08:00 am I saw the variables in the console. Unfortunately, from a certain moment around 10:00 it was no longer possible. I would like to understand if it is a problem of my provider, network clogged due to the Corona or other.
I wish you all best and Happy Easter.
Valentino

Happy easter to you too!

and when you say the variable in the console, do you mean here?
https://console.particle.io/devices

I went now and I can see the variables of my photons. What device are you using?
thanks

Hi Guglielmo everything is ok but that’s exactly what amazes me (at the moment I have two module Photon and Argon).Why does it work now? I also tried an apps with about 10 variables and is ok. I am developing apps for temp and humidity measurement system to make fans work and these cases disturb me. Is it my problem or does it come from where?
Best and Thank You from the support.
Valentino

Sorry Gustavo yes console - variable but same time if I call the variable with APi in a Browser Microsoft Edge or Google Chrome or with Visual Basic.
Best and again Grazie

I cannot explain why it works now. However sometimes I make mistakes in the firmware inadvertently and maybe that’s what happened in your case?
I’ve been using Particle for the last 7 years and everything is pretty solid, so build your projects with confidence. Of course, sometimes some things stop working but for instance I had to reboot my photon controlling my garage one time in the last year when there was a black out.

Good luck!
Gustavo.

Hello
just to clarify, I have some Particle Boron and Photon modules that are running, the variables respond to the get with the right values. Unfortunately in two that I use to perform tests in the early morning before 08:00 they work well and they respond to get, after this time if I run flashes of my code the variables are no longer visible in the console. Same thing if I run either from Iphone or from PC the Tinker app I don’t see the variables in the console but neither does the app work on the mobile phone.
As already expressed yesterday I want to understand if this comes from an overload from my provider or an overload from the Particle cloud.
Best Valentino

This is the Last Vital when i flash tinker from Iphone
LastVitalGiove13042020

{“device”:{“network”:{“signal”:{“at”:“Wi-Fi”,“strength”:100,“strength_units”:"%",“strengthv”:-42,“strengthv_units”:“dBm”,“strengthv_type”:“RSSI”,“quality”:100,“quality_units”:"%",“qualityv”:48,“qualityv_units”:“dB”,“qualityv_type”:“SNR”}},“cloud”:{“connection”:{“status”:“connected”,“error”:0,“attempts”:1,“disconnects”:0,“disconnect_reason”:“none”},“coap”:{“unack”:0},“publish”:{“rate_limited”:0}},“system”:{“uptime”:19,“memory”:{“used”:94472,“total”:161016}}},“service”:{“device”:{“status”:“ok”},“cloud”:{“uptime”:2,“publish”:{“sent”:2}},“coap”:{“round_trip”:287}}}