Connect electron to internet without cellular coverage or via ATT Microcell

Hi Guys,
Is there anyway to connect an Electron to the internet without Cellular coverage? Or with an ATT Microcell?
My house is out of Cellular coverage, but I have good internet and Wifi.
I use an ATT microcell to connect my cellphone when at the house, works great.
Does anyone have a way to connect thru the Microcell (small local cellular gadget that lets my phone use my internet for calls and data just as if I was next to a real cell tower.)

I’m trying to develop firmware for use elsewhere, but I can’t flash it unless I go into town.
I believe I did flash it once via Particle Dev, but can’t seem to do that anymore, not sure why.
I am unable to get particle CLI to run on my Mac, spent about a week trying to get that to work in the past, gave up!

Thanks!

Hmm… If you’ve got WiFi, you could do development on a Photon, since that should work just the same. You can then later swap it for an Electron. (also a bit more economical than flashing over cellular)

We could probably help you with that. It’s kind of an essential tool when developing on Particle, a very useful one at the very least.

I have heard a report that the Electron does not work with the AT&T Microcell, even with an AT&T SIM card instead of the Particle SIM. It is possible that this report was mistaken, but the AT&T web page for the MicroCell does state "For use with AT&T wireless devices only; not compatible with other wireless systems.”

Thanks @Moors7, I’m already using cores and photons, but was hoping to have a way to do it at home with the electron. When I’m ready to put some time into the CLI I’ll let you know!

@rickkas7, Thanks for sharing that, I hadn’t even thought of using an ATT sim in it. The microcell only lets thru phone numbers that you register to the unit online. I doubt an iPhone sim would work, but I do have one, hmmmmm.

An AT&T nano SIM card (from an iPhone 5 or 6, for example) will fit in the Electron and should work, at least without the Microcell. To fully connect to the cloud you’ll need to insert this line in your code:

STARTUP(cellular_credentials_set("Broadband", "", "", NULL));

Unlike Wi-Fi settings, the cellular APN is not stored in configuration flash so you always need to add that line to any program that uses a 3rd party SIM card. The string “Broadband” is specific to AT&T. Just take the line out when you put the Particle SIM back in.

It’s certainly worth a try if you have all of the pieces on hand.

Cool, I’ll try that out.
Thx