Community Upgrade

I’m upgrading the community right now. When I restart in a bit, it will be down for just a minute. Back in a flash!

All done! We’re now on discourse 0.9.4.

When I click search, I just get a dropdown where I type in the text, and a never-ending busy indicator. Is search working for anyone else? I’m on Chrome v27

Yep, I get the same thing in the latest Chrome and latest Firefox.

I’ve been getting the same thing too; sorry, I know it’s frustrating. No time today to debug—the search route is getting a 500 error, which you can see in the javascript console. Might be a bug in discourse, but I’d have to dig through the logs to be sure.

Looks like the search at works ok, and no chatter about broken search on the github repo, so probably a setup/upgrade issue.

The search also didn’t work before the upgrade. But I think it is better to concentrate on the core and not on the forum search :wink:

1 Like

Giant leap closer to fixing the search here in the Spark community—see my post on

@zachary Wow, if you put half that much effort into Spark Core… ((boom)) my brain explodes at the thought of how awexome it’s going to be. :smile:

Have you tried upgrading to Rails 4 and see if it works?

1 Like


Thanks @BDub!

And yes, I can assure you that, without a shred of doubt, every single member of the Spark team is putting much more than half that effort into the Core every day. :sweat_smile:

Our search works now!

@BDub—We’re still on rails 3, but I suspect upgrading would also fix this issue. However, Sam at discourse said rails 4 is still experimental, so it would probably cause other problems.

The solution was that I needed to add some indexes that somehow never got added (or got dropped) in the installation process.