Code uploading issues with the P1

I got my P1 board updated to 0.4.3, which partially solved the i2c issues… However, now I’m having the following problems on my P1 board:

  1. I can’t upload code. My P1 board is connected (breathing Cyan), but when I hit “flash” on the online IDE, it doesn’t do anything and then times out. Other times, it says “flash successful” immediately after I hit flash, and it never flashes.

  2. I tried to download the firmware.bin file of my verified code, then tried flashing through the CLI using “particle flash myDevice firmware.bin”, and that doesn’t work. I get this as a response:

    {“ok”:false,“code”:500,“errors”:[{“error”:“Timed out.”}]}

Are others experiencing similar problems with 0.4.3 on the P1? The weird thing is that the upload worked fine just a couple days ago even on 0.4.3.

Edit: Ran it through another factory reset and it seems to be working again…

This could be your application code interfering with the device pulling an update from the cloud.

If this happens again, try using Safe Mode instead of a factory reset - it will get the device on the cloud much quicker and without resetting wifi credentials.