P1 Continuous Hard Fault after OTA update

I’ve been seeing this issue with our first run of P1-based boards where the P1 will go into a continuous hard fault SOS code flash when I try to do an OTA firmware update.

The update appears to happen successfully, and when the device resets it starts the hard faulting. It flashes the code, resets, flashes the code again, etc indefinitely.

However, if I power cycle the device, it boots up properly into my new application code.

For the units I’m testing currently where this is repeatable 100% of the time, they are running system firmware 0.6.2 and I’m targeting 0.6.2 for my app code. I’m using particle dev.

This happens whether I try to flash my application code, or Tinker. I’ve also tried both the web IDE and particle dev, same result.

As a side note, I can flash using DFU without issue and don’t need to power cycle.

Anyone have any clue what could be happening?

Ping @rickkas7

Just to close the loop on this one, the issue was that we had tied WL_REG_ON to 3.3V. Allowing the pin to float solved the issue.