Cloud thinks my Photon is a Core

So I’ve been working on a project and developing using two Cores. Now it’s time to make this work on some Photons.

I’ve had some problems during setup. The particle setup command didn’t work. Same problem as this thread and same solution

Then my Photon had the same problem as in this thread. Again same solution.

Now my Photon connects to the cloud. I have claimed it and it shows up in the dashboard. But in Particle Dev, under devices, the Photon shows as a Core. I can program it via Particle Dev and via command line but code that used to work on the Core sometimes (during runtime, not immediately at startup) chrashes and the led blinks SOS in red.

Does anyone know why the cloud thinks my Photon is a Core and how I can fix it? I’m not sure my problem is related to this but it is a good guess. I have one Photon which didn’t show these problems, is recognized as a Photon by the cloud and works perfectly.

@mdma is probably your best bet here. I’d recommend not using particle setup, as it did not work for me with my Photons, but rather use particle serial wifi and claim it manually.

I ended up running particle serial wifi but I also had to generate new keys to connect to the cloud. Then I claimed it and named it, but then it shows up as a Core.

The issue seems to be when the Photon recieve a event from the cloud. Upon event, the Photon crashes and blinks SOS in red and then reboots.

I have a Core running the exact same code (not the same binary) and it worsk fine. It does what it is supposed to do while the Photon chrashes. I’ve run these side whith repeatable result.

The one Photon I have whitch the cloud thins is a Photon works perfectly, both sending and recieving events.

Is there any difference in the event message being sent to a Photon vs a Core than can cause the unit to crash if the wrong one is sent?

Hi @skoelden! Please send me the device ID of your Photon with the personality crisis and I’ll talk to our cloud guys to make it look like a Photon!

I don’t think this is related to the SOS (red LED) you’re seeing, so we should probably take that in a separate thread. If you can produce a minimal application that has the problem that will help us track down the issue. Thanks!


1 Like

Thanks for your help. I will see if i can write a simple program that shows the error.

But do you have any idea why the Photons are registered as Cores? Could it have something to do with the manual key generation perhaps?

I have more Photons that I have not fired up yet and It’s not a great solution in the long run to ask you guys to fix them manually.


Now my Photons show up as Photons, thanks!

I’ve found what was causing my other issue, and the mislabeling was not the problem. I’ve written about it in this thread.

1 Like

@mdma This just happened to me, too. Something got borked in setup and I tried resetting the keys but didn’t realize that I needed to use ‘photon’ with ‘particle keys new’. Saved and uploaded the keys and my photon connected but showed up as a core.

I realized the problem and regenerated, saved and uploaded photon keys. It connects to the cloud but still shows up as a core. And when I try to flash firmware, it takes the update, resets and starts flashing purple (I’m assuming because there’s a linker problem?)

I can pm you the device id if that’s what it’ll take to get it showing up back as a photon.

1 Like

Same thing here. My lovely photon has now been reborn as a core after running particle keys new.

Is there a solution here, other than pm-ing the device ID to the good folks at particle?


I too am having the same problem. Has there been a fix announced? This all seemed to happen after not being able
to claim the device and doing new keys.

I also just ran into this problem also.

Couldn’t get my new photon to setup using the iOS app, so I used the computer. Interestingly enough, after trying “particle serial wifi” it wouldn’t pick up any wi-fi networks. Entered the credentials manually and it connected but gave the quick orange flashes. So I used “particle keys doctor id_of_my_photon” after entering DFU mode and it connected. It auto updated to 0.4.7 (I would assume 0.4.7) as well. To be safe, I then did a manual firmware update using DFU to update to 0.4.7

The weirdest part about mine is that it shows up as a Photon on Particle Build, but a Core on the iOS app. Very strange.

I have the same issue.

My Photon started showing as a Core right after I ran the keys doctor util.

I have two Photons. The newest one is recognized as a Photon, but my older one is recognized as a Core. I’m not sure how or when this happened. Can you fix this for me, or point me to detailed instructions for how to fix it?

Hey Debrota, please fill out the form here with your device ID and I’ll get your Photon-turned-core fixed! :slight_smile: