Cloud compiler issue - 504 Gateway Time-out

I’m unable to compile from CLI at the moment. The error I receive is:

Flash device failed:
<head><title>504 Gateway Time-out</title></head>
<body bgcolor=“white”>
<center><h1>504 Gateway Time-out</h1></center>

@jenschr, I just compiled with CLI from home (Canada) and had no problems. Are you behind a residential gateway or a commercial one (school, office)?

Am behind some office switches. Is there any URI that I can ping to check?

There’s no known outage at the moment. What device and system firmware version are you building for so I can make sure it’s not a specific compile farm configuration that’s affected.

1 Like

Building for P1 on 0.70, but it just started working again. I tried compiling maybe 7 times with error and then it just started working without any changes to my network setup. It’s happened before, but usually resolves within an hour or so. Anything I can do to easily debug this?

… and then I got the error again :-/

I don’t see anything in alerts or obvious in the cloud logs. And I can build for 0.7.0 for p1 with the CLI; I tried 10 times and all succeeded.

Is this sensitive to the size of the project? In other words, does it fail if you build a minimal program or is it affecting all programs you try to compile? And does it fail immediately, or a like a minute later (it’s actually timing out).

1 Like

Oh… I just realised what happens and this is 100% reproducible. If my device is in setup mode or have not finished connecting to the cloud after having been in Setup mode, I will get this error. My PCB is mounted inside a machine and I didn’t catch that it had entered Setup Mode.

To reproduce, start the device enter Setup mode and try to Flash. It seems that the cloud is not notified that Setup has been pressed and thus the unit is no longer online. Since the device is marked as being online, it still tries to Flash it.

It would be great to get a more clear error such as “Device not online/found”?


Oh, that makes sense - it’s a flashing error, not a compile error. And, yes, a better error message would be helpful.


Yeah. It compiles fine :slight_smile: