Chrono: No such file or directory


I am trying out the CMSIS-NN library on the photon for my project. I have imported the libraries and tried to compile with an example but encountered the following:

/inc/application.h:33:18: fatal error: chrono: No such file or directory

This error message has occurred multiple times when I try to include some libraries that were relatively big. I ctrl+clicked on chrono in application.h and it does lead to the chrono library in the following directory:

I am wondering how to solve this issue, as I could not find anythings similar on this forum. Thank you!

I ran into this problem while trying to

#include "Particle.h"

in my .c source file. I fixed that by changing the file extension to .cpp, so it is compiled as C++, not as C. Hope that helps.

1 Like

Hi, so all libraries must be changed to file extension cpp? I will try this!

Fixed it for me, thanks @ishturma!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.