Checking Core is on the most recent everything

I want to have another go at getting my recalcitrant Cores working properly after several abortive attempts (I get fed up and leave them sat doing nothing for months at a time!)

Before I start, to maximise my chances of success and minimising sadness, is there a convenient way to check each Core is on the most recent everything (firmware,bootloader etc etc) ?

thank you

The most recent CLI should give you most info via

particle serial inspect

Thanks - might I run that and report back or should it be relatively easy to then compare with online documentation? What I found confusing before was that all my various firmware/bootloaders were out of date but nothing but the helpful people on this forum prompted me to update anything. :slight_smile:

.1. So I tried to use the most recent CLI and got this

C:\Users\Office>particle serial inspect
Serial err: Error: Opening COM3: Access denied
Serial problems, please reconnect the device.

! serial: Serial problems, please reconnect the device.

I should mention that running “particle doctor” seems to work.

.2. I tried to download and run the firmware manager and get a kivy fatal error due to my opengl version.

.3. I tried to flash my Core from the web GUI build and “flash is unsuccessful”.

This is what I remember about Particle and why the last heard from date on all of my Cores was June 2016. :frowning: (!)

Thanks for your help ScruffyR

OK after running Zadig and running the Particle Doctor twice and then putting the device into listening mode I was able to obtain the following info (see pic)
(The web console says firmware unknown.)

Just tried to flash some code to the Core via the web GUI. This now works (following running Particle Doctor twice) but it doesn’t seem to have updated the firmware at all.

The Core uses a monolithic build. There’s no system firmware to update. What you build on the IDE, is what’s getting flashed.

Thanks Moors7, I understood (perhaps wrongly) that some of the underlying chips etc had their own firmware which could be updated/upgraded to improve WiFi reliability etc. My Cores drop WiFi connections all the time.

The only one I’m aware of is the CC3000 WiFi module.
This gets updated via

particle flash --usb CC3000

But the CC3000 is also known to be a bit unreliable and suffering from amnesia. So the best option IMO - although I also hate early obsolescence - is to move on to the Photon.
I’ve got several Cores but am not using one of them anymore.

1 Like

This time I got:-

"C:\Users\Office>particle flash --usb cc3000
Found DFU device 1d50:607f
spawning dfu-util -d 1d50:607f -a 0 -i 0 -s 0x08005000:leave -D C:\Users\Offi
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to

Opening DFU capable USB device...
ID 1d50:607f
Run-time device DFU version 011a
Claiming USB DFU Interface...
Setting Alternate Setting #0 ...
Determining device status: state = dfuERROR, status = 10
dfuERROR, clearing status
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 1024
DfuSe interface name: "Internal Flash  "
Downloading to address = 0x08005000, size = 25068
Download        [=========================] 100%        25068 bytes
Download done.
File downloaded successfully
Transitioning to dfuMANIFEST state
Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!

Flash success!"

Thanks ScruffR! I don’t suppose there’s any way of seeing what the CC3000 firmware is before/after the flash?

I don’t know of any but Particle engineers might

@daneboomer, TI’s last “working” CC3000 firmware is what is flashed over when you run particle flash --usb CC3000. They no longer support this device. After flashing that code, you should do a particle flash --usb tinker which will download tinker to your Core with v0.6.4 system firmware most likely. Then you can confirm if your Core is working properly and flash over any new app/system firmware as you desire (since they are combined into a single file for flashing).

The CC3000 was a first from TI in a generation of WiFi chips. It used an 8051 MPU and not lot of flash so TI was very limited in getting a lot of code in there, especially when bugs cropped up. And as @ScruffR pointed out, it was prone to amnesia and just plain failure. This was one key driver for moving to a Broadcom platform for the Photon. :wink:


Thanks @peekay123.

Just been reading back through my old messages …isn’t there a “deep update” I need to flash each of my Cores with? I will try to do that tonight.

@daneboomer, I believe using CC3000 provides the deep update.