Charge status LED Boron404x

somehow completely lost all activity from orange charge status LED on particle boron 404x. 3.7v lipo connected to jst port. slide switch to ground on EN pin for turning device on and off. it charges fine when connected to usb through either computer or charging block, but the LED no longer activates. i definitely messed with pmic settings at one point, but i used this code to reset it:

// Reset power manager settings to default values

void setup() {
    // To restore the default configuration
    SystemPowerConfiguration conf;
    System.setPowerConfiguration(conf);
}

tried restoring the whole board to factory settings, nothing has worked. maybe some pmic faults? is there a way to read those faults? any ideas to get the charge status led back?

thank you all!

There is no PMIC setting to disable the charge LED, and it's just an LED and a current limiting resistor connected to a pin on the PMIC. If you disconnect the battery, power on the device by USB, then put the device in DFU mode (blinking yellow), does the charge LED flicker?

no it does not

In that case, the most likely cause is either the PMIC or the LED has been damaged.

i think you're right. i think i dropped a tiny piece of solder on a pad near the led leg and its shorting. i'll see if i can remove it properly. thank you!