Cell service just stopped [Resolved]

We are running three prototype devices using Electrons (2G). Everything was functioning well until about 2 hours ago, which suddenly the Electrons started blinking green (with an occasional blinking white that quickly transitions to green). The Electrons are otherwise functional, but cannot connect to the cell network.

Everyone on our team continues to get cell service through our phones, but nothing through the Electron.

(The biggest surprise was that when we contacted Particle tech support - something we’ve never had to do or tried before - and we were told that it would take 3 business days to get back to us. Three days? Really? We have a team of 5 people who are pretty much blocked until this is resolved. Ugh.)

Anyway, we have reflashed firmware (user and system), power cycled the devices, the done ritual dances and incantations (although we have not set anything on fire - yet), but we still only have the blinking green light of doom. Again, this is not just one Electron; we had three functional units until a couple of hours ago, and they all went off the cell grid at pretty much the same time.

Help!

L3

Do you have any 3G electrons? Could it be the 2G in your area has been taken down? Are your phones that are working on 2G?

1 Like

Have you checked the ICCIDs at dashboard.particle.io to ensure that they haven’t hit their data caps or been manually deactivated?

The auto-reply reads,

Thanks for writing to us! Your email has been entered as a support ticket in our system. If you are getting this email on Monday-Friday, someone is probably already taking a look and sending out happy thoughts while they work on an answer. If you don’t hear from us within 3 business days, please don’t hesitate to write to us again.

That’s only meant to indicate that if you haven’t received a reply in three days, something has probably gone wrong. In general, our target is to reply to all customer support inquiries within 24 hours (10 business hours) of their being submitted.

1 Like

Thanks, Will. I was surprised when one of my guys told me that - you guys have always been awesome - looks like something just got lost in translation…

Cheers,
L3

Will,

We’re OK on the data caps - we don’t use much data (thus the decision to go 2G). And I don’t know how we would have manually deactivated these devices - and they all went offline more or less at the same time.

This is weird, I know, and appreciate any help you can provide.

Cheers,
L3

@Hypnopompia,

Nope, sorry, we’re just using 2G Electrons at this point. I don’t think the phones are 2G. So this could be the issue, but I don’t know how to chase this down. Any ideas would be appreciated.

Cheers,
L3

Hi @leo3linbeck,

Please give the Tinker USB Debugging app a spin. We might be able to infer what’s going on based on the debugging output. https://particle.faqt.co/share/h867h4 Please send this to me in a private PM. Thanks!

@BDub,

Will do. Much appreciated. Cheers,

L3

Hi @leo3linbeck and @BDub ,
I’m having this same problem; Electron 2G was working fine yesterday, today its blinking green -> white -> blinking green etc. endlessly, no connection to the internet at all. I ran the tinker-debugging and got a bunch of error messages like this:

0000038702:INFO : void manage_network_connection() (116):Network Connect: SPARK_CLOUD_CONNECT && !network.connected()
0000038702:INFO : virtual void ManagedNetworkInterface::connect(bool) (282):ready():false,connecting():true,listening():false 

Is the the same error you were seeing, and did you ever figure out how to fix this issue?
Thanks!

Updates: I have another 2G Electron, so I moved my SIM to that one to see if it was a problem with my SIM (which is a 3rd party SIM) and the second Electron showed the same behavior (no connection, just green flashing forever), so it seemed to be a SIM issue. I had another 3rd party SIM so I tried that one out and still the same problem! So now I’m totally confused, two Electrons and two SIMs both failing the same way all of a sudden. Any help would be very appreciated!

(also for the record, I do have Particle SIMs but they also do not work. They seem to exhibit a pattern where it gets to cyan blink but then flashes orange 3 times before resetting. I’ve seen in other threads that this was a SIM issue that I believe just required replacing the SIMs but since I have to use 3rd party SIMs for my use case anyway I never looked into a replacement)

Since this is a 2G device and 2G is being phased out by the carriers, have you considered that your carrier might have turned off a 2G tower in your area?

You could try moving the electron to another area that might have better 2G service.

@cstites,

I resolved it in two ways:

  1. [Temporary] I just left the 2G on for another 24 hours, and the problem resolved itself. Based upon the logs I got out of the system (thanks, @BDub!), it was clear that it was a problem with the cell network or tower.

  2. [Permanent] I switched everything over to 3G. My spidey-sense told me that with 2G being phased out in the US, this was just the first of many interruptions and hassles. I really liked the 2G option, but I’m out of that game now.

Hope all goes well for you, and that this was helpful. Cheers,

L3

3 Likes

Glad you were able to get it working again! Let us know if you run into this problem in the future.