Can't update Electron firmware from Windows [Solved]

Hey there all, here’s my environment:
-Win 7 machine
-Electron at 0.4.8 firmware currently
-Electron in DFU mode (flashing yellow…but the red portion of the LED is also flashing)

I’m following these instructions to update to v0.5.3 firmware:

Zadig reports that my device is running WinUSB v6.1:

Particle CLI is reporting the following when I try to push the part1 and part2 binaries:
“Invalid DFU suffix signature
A valid DFU suffix will be required in a furture dfu-util release!!!
No DFU capable USB device available”

Where could I be screwing up?

Try doing:

dfu-util -d 2b04:d00a -a 0 -s 0x8020000 -D system-part1-0.5.3-electron.bin
dfu-util -d 2b04:d00a -a 0 -s 0x8040000 -D system-part2-0.5.3-electron.bin


No luck, same feedback.

You could try another driver via zadig.
I have good results with libusbK

And as @nrobinson2000 pointed out the Electron needs 2b04:d00a - you’ve used the Photon’s PID d006

Tried it with libusbk - same message “No DFU capable USB device available”

Can you repost your actual command and error message?

I copied nrobinson2000’s lines into a cmd file and ran it.

parts 1 and 2 of the firmware binary are in the same directory.

Maybe you can try another USB port and other USB cable.
Can you also post a screenshot of your DevMgr showing the device?

When loaded with libusbk the Electron appears here in the Device Manager:

When loaded with WinUSB it appears here as Photon DFU Mode:

Okay I found a successful combination by switching the USB cable, USB port used and then back to WinUSB. It still reports an invalid DFU suffix but I suppose that’s normal? Thanks all!

1 Like

@pNrie, I guess you deleted all your posts since you found a solution?
Instead of editing away what you wrote earlier, it might be good to know what you found to be the reason and the solution - even if it was on your own side :wink:

@ScruffR Yes, sorry, the original question posed by @markjones.cpe looked like the issue I was having and after an hour of debugging I was certain it was. Turned out to be a faulty *.bin file I was trying to load to the Electron via CLI and had nothing to do with the original post. I thought it better not to embarrass myself or distract from the original issue.
Maybe it should be possible to delete posts to the forum altogether?

1 Like

It is possible to delete your own posts.
You should find a dustbin icon in the bottom line of your posts (maybe hidden behind the … ellipse) - but honesty isn’t embarrassing and might help others who fell for a similar misconception.

I agree with @ScruffR, I feel like this can be helpful for others and if you don’t want to delete it, you should leave it up. I’m glad you were able to fix the problem @pNrie!

Tis true, the dustbin hides under the ellipses

1 Like