Cant seem to install spark-cli - Loggin in as admin using sudo -s [Solved]

Hi, my spark core needs to be claimed. I’m having a lot of difficulty installing the spark-cli using the commands provided.
I tried sudo, I tried sudo -s, please see the attached screenshot.

Has it got anything to do with the LED ‘breathing’ magenta?

Thanks
Vish

You shouldn’t have to be root to use npm on a single user osx machine - try the following:

$ whoami
[your-username]
$ sudo chown -R [your-username] /usr/local
$ sudo chown -R [your-username] ~

The last two commands reclaim your user access rights for non-system related installed files and for all files/dirs in your own home directory.

From there on npm, brew and so on won’t need root permissions via sudo anymore, so even a

$ npm install -g spark-cli

should smoothly work!

Its a pure software issue without any connection to the Spark Core itself.

Good luck :wink:

1 Like

Thank you for your prompt response. I tried the suggested changes, this is what I’m seeing now:

Could you make another screenshot/copy of the information some lines up?

Sure, it’s broken down into two screenshots:


Execute

$ sudo xcodebuild -license

and try again :sunflower:

1 Like

Thank you, I did it and it said something about me not agreeing to the Xcode license, I had assumed that message wasn’t related, but I went into the Xcode GUI and agreed to the terms and now the Spark CLI works just fine.

Thank you very much for your support!
Vish

4 Likes