Cant connect to WiFi?

Mac user:
Got a new photon (well old one I bought that I brought out of the box after like 2 years), and did particle setup. It gets to reading the available WiFi’s and I get this error:

> ? Found "Photon-XJW3". Would you like to perform setup on this one now? Yes
> ! PROTIP: You will need to know the password for your Wi-Fi network (if any) to proceed.
> ! PROTIP: You can press ctrl + C to quit setup at any time.
> ! PROTIP: There was a network error while connecting to the cloud...
> ! PROTIP: We need an active internet connection to successfully complete setup.
> ! PROTIP: Are you currently connected to the internet? Please double-check and try again.

I am connected to the wifi and internet, this post is a testament of that, so not sure why particle setup does not work.

I tried doing sudo particle setup, but same error.

Which device mode at the moment?
What particle device doctor says?

I always use the “manual” setup process to connect photons to Wi-Fi and claim them.

Device mode is listening mode. I’ll try the device doctor and let you know.

@r0b0tn1k If it has been in the box for 2 years I would start by putting it in dfu-util mode and flash via usb the latest Device OS and bootloader and tinker, then do a Particle setup to claim it and setup wifi. I recently started adding in the flash --serial bootloader because I had a series of mismatches on devices that I had ordered a year back and had 0.5.3 on them - easier to add 10 seconds to the setup process than spend 20 minutes sorting it out later.