Can't connect PHOTON, led between green and cyan [SOLVED]


#1

Hello,

I tray to connect myPHOTON to the cloud of particle, from the terminal with the command “particle setup”, but when I reach the point where particle cli check the credentials of the wifi, the led of the device begin to blink in green, and a few seconds in cyan, and then again in green. Never breathe in blue.

Which can be the problem? I see my wifi settings, an I think all is ok. DHCP is active, there is no firewall activated, …

Any ideas? What can be the problem? Thank for your help

Regards


#2

When connected to the cloud it should breathe cyan not blue.

Have you got MAC filtering on your router?
Try to temporarily deactivate all security options on the router and just add them one by one, to pin down the source.
Have a try with a different WiFi (e.g. your phone as AP).

I’m not aware of these restrictions on the Photon, but the Core didn’t like WiFi channels > 11 and 5GHz (n,ac) networks. Try “correcting” this too, maybe :wink:


#3

Have you managed to setup before or it’s an entirely new device?

Is is flashing cyan with occasional red flashes?


#4

Thanks for your help,

kennethlimcp, there is no red flashes, only I see that the device try to connect to the wifi, and in a moment, the led blinks in cyan, and then return to green. I have not changed the firmware, maybe I need to update?

ScruffR, yes, I search in my router and there is no MAC filtering. And, as you suggest, I try with other WIFIs. Then I noticed that if I try to connect in the wifi of my home, the device connects without problem, but in the office, where I need it, the device doesn’t connect.

I try in the terminal (I am in Linuxmint) this command: iwlist scan, and it returns to me the number 10 as my wifi channel.

Anyway, probably you are right: The problem are in the router settings. I will try to search it and I will say If I achieve the solution. Thakns again.

if anyone has any other ideas, is welcome.

Regards


#5

When you say you’re using it at your office, further questions arise.

Could it be that you’ve got a WiFi WPA/WPA2 Enterprise network at work (which is currently not supported on the Photon and most likely never will be on the Core)?
Have you got a captive portal at work?
Are the required ports for cloud communication (e.g. CoAP 5683) open?


#6

thanks for the quick reply,

When I say office I mean a particular house where I have a connection to internet with a typical router as if I were a regular user, not an enterprise. I share connection with another person in the same place, and both of us are the “office”.

So, answering your last questions, we don’t have that enterprise network (the wifi is WPA2), there is not a captive portal and the last one I don’t understand very well, probably because I don’t set the ports manually. How I can check that?

Again, thanks for your help


#7

If you’ve got a consumer router it most likely will have all ports open unless you close them.
And if you ISP is not overly paranoid they will go through there too :wink:

But one thing I would like to repeat here, since you only said

But you haven’t said anything about 5GHz (801.11n,ac) settings of your router. Try to deactivate n & ac to ensure a 2.4GHz band.

Since it obviously has nothing to do with the device itself it must be the network - unfortunately there can go several things wrong.

You could also try to reset the WiFi credentials by pressing MODE/SETUP 10sec till the RGB LED flashes blue - just in case your Photon remembers an old set of credentials that might have been entered incorrectly (unlikely, but who knows).


#8

Hello,

If you need some information about my network:

                Address: 20:25:64:1D:DD:64
                Channel:10
                Frequency:2.457 GHz (Channel 10)
                Quality=63/70  Signal level=-47 dBm  
                Encryption key:on
                Mode:Master
                IE: IEEE 802.11i/WPA2 Version 1
                    Group Cipher : TKIP
                    Pairwise Ciphers (2) : CCMP TKIP
                    Authentication Suites (1) : PSK

I am with you, it’s the network, sure. And yes, I reset the WiFi credentials. It looks like I’m at a standstill.

Thanks for your help once again. If I solve this problem, I will write here the solution.

Regards


#9

@nmarmon, has the Photon been able to connect to other Wifi network like your mobile phone hotspot?


#10

Hello kennethlimcp,

yes, I try to connect photon in other Wifi network and it works. I don’t know why photon doesn’t connect in the current wifi network. I suspect that may be the compatibilitycompatible the router, but not sure. The router is a EPC3825. perhaps it is incompatible with photon?

Regards


#11

@nmarmon, the BCM43362 offering from Broadcom should be more robust so it would be good for us to understand the issue better.

Just wondering what’s your wifi name?


#12

The wifi name is Euskaltel-RJSX, thanks.


#13

If your try the following command telnet device.spark.io 5683 what do you get back?


#14

hello sorry for responding so late, the command returns the following lines:

Trying 52.0.31.156…
Connected to device.nodes.spark.io.
Escape character is ‘^]’.
�j��Connection closed by foreign host.


#15

I finally solved the problem. I figured it was some of the router, and apparently it was the firewall settings. The router is a Cisco EPC3825. I went to the section where disable the firewall and it worked. The fact is that it did not do it immediately, and spent some time until the LED on the board became cyan.

Thank you all for helping me.

Regards


#16

That’s often the case: I also assume things, but after double checking, I prove myself wrong :wink:
Good to hear that it works now :+1:


#17

It works i change the channel 11 in my router to chanel 9 and desactivate the mac protection and later connect to particle console.particle.io web and later go to my devices and go to OTA updates and activatte and now my particle photon is always coneccted to wifi. im so happy.