Can't connect, Can't do much of anything

Hey, a roller coaster of emotions with my Particle Button.

I connected it to my home wifi and wrote a program. Brought it to work and I couldn’t get it to connect. After 2 hours. In the process, I tried a lot of stuff on the website. Firmware upgrade. Device Doctor. I think what’s listed there is overkill and has my device in a really bad state.

Now I’ve brought my device home (where it once worked) and still cannot get it to connect. I was hoping I could do a factory reset, but I can’t get beyond a flashing yellow light. After what looks like a successful wifi setup, I can’t get it to connect to the cloud. I also don’t get LED indication that it’s connecting.

Have I bricked the thing or is there anything I can do to get out of this?

Your device id is undefined
Your system firmware version is undefined

That’s probably bad, right?

Try DFU mode with “Particle update” and “Particle flash --usb tinker”. Furthermore, hold the mode button until it blinks blue rapidly to remove all credentials. Then, try setting it up again.

Also, it’s helpful to know what the LEDS are doing so we can get an idea of the state it’s in.


How did you claim it?

Thanks for the response. Shortly after I posted, I found this and pretty much went through the steps you outlined. Except I only did particle flash --usb tinker. Things seemed to work after that, so I didn’t risk another step.

It would be helpful to know that these commands are doing. Is this basically flashing a default app to the device?

So now I took it to another wifi environment, put it in setup and changed wifi networks. On the second try, I thought it had failed because it ws flashing green. I went to hit reset again and as soon as I pressed it it went flashing cyan and then breathing cyan. It connected!

Then it stopped. Now it blinks cyan, then sometimes blinks green, maybe a splash of orange/red. When I read here it says to do a manual firmware update and maybe reset the key? I’m afraid to do this.

Also, I’m trying to eliminate a weird wifi network as a variable by connecting to a tethered phone. I get pretty much the same LED sequence on both wifi networks that I attempt to connect to.

Did particle update and then it finally connected to wifi/cloud.

Tried to flash my app through the web IDE… now it’s blinking just about every color there is. Primarily in the sequence: cyan > briefly orange/red > green.

The orange blinking is probably an issue with your keys. Try running the instructions here to repair your keys.