Cant compile code

I keep getting this message when try to compile my project that worked earlier today

Error: Could not compile. Please review your code.

Anyone know whats going on here?

Update, complies from the dev ide just fine

Same problem! Can’t compile code in the web IDE, it gives me error 400 if I try to flash, and a generic error if I verify. No info on what’s wrong with the code. This problem occurs if you have an error in your code - hopefully it’s fixed soon because the IDE is pretty much useless if it doesn’t show compile errors. Additionally I tried using desktop IDE and it fails to load my devices in the device list. So I can’t move forward this evening.

Following up, support responded to my ticket - engineering is aware and working on the issue.

Great thank you, i will stop deleting my code line by line until it compiles… Seemed if i deleted enough references to the libraries used i could eventually get it to compile

Ha! Yes, at first I thought it was related to my libraries, but if I simply delete a semicolon it recreates the problem.

okay that makes sense, there is error in my code somewhere it just cant tell me where. Got it

Hi all, there was an issue with this particular error reporting mechanism in the Web IDE yesterday, but it should be solved by now. Please, please let me know if you continue to experience this issue! Sorry for the difficulties.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.