Cannot flash new code to my Electron via USB while in Listen Mode

I am using an Electron with the Asset Tracker shield and have been developing my code using the WakeOnMove code as a base. However, I can no longer flash new code to my Electron. I tried downloading the basic “Blink an LED” firmware.bin file and flashing it using the CLI, but I just get “Error writing firmware…Transfer cancelled, undefined”. The device was in Listen Mode while trying to flash the code, went magenta (twitched a bit) and went back to Listen Mode.

Here is a screenshot of the CLI:

Here is a gif of the color transitions:

I would be greatful to receive some help :slight_smile:

does it work in DFU Mode particle flash --usb firmware.bin?

Or put the device into Safe Mode first and then enter Listening Mode from there.

Here is the results when in DFU mode:

The same error as before occurs when beginning in Safe Mode then entering Listen Mode

I guess you are trying to flash a binary that’s meant for Core not Electron

You cannot do that.

1 Like

The firmware.bin file I am trying to upload is the “Blink an LED” example from the Particle Web IDE. I have been able to upload this code in the past. What has changed now?

You need to set the build target in Web IDE


Sorry, I feel stupid. I didn’t realize the need to select a device each time I downloaded the binary firmware.bin file if I was uploading via USB instead of through the 3G network. I assumed (incorrectly) that it would know my target based on my previous firmware uploads.

Thank you for your patience and help! Much appreciated :slight_smile:

1 Like