Can not flash new code after firmware upgrade to 0.6

I just got my electron and GPS tracker set today. Powered it up and flash the LED light code. Worked fine. Then I want to try the GPS feature example, there was message saying I need to upgrade firmware. Then I did it, first 0.5 firmware, then 0.6 firmware. After than, I can not flash any bin code through USB cable. Below is the message in terminal. Please help. Thanks a lot!

! PROTIP: Hold the SETUP button on your device until it blinks blue!
? Press ENTER when your device is blinking BLUE
sending file: firmware.bin
Assertion failed: (timeout != -1), function uv__io_poll, file …/deps/uv/src/unix/kqueue.c, line 178.
Abort trap: 6

Update 1:
I tried over the air flash, it works. But why does USB flash stop working?

Update 2:
In the browser IDE, I clicked on Device, it shows my device firmware as: “On the device: 0.4.8”. Why is that? The 0.5 and 0.6 firmware update software told me update completed. And open the firmware update software again, it shows the device has 0.6.0. which does not match IDE’s device info under system target firmware “On the device: 0.4.8”. What is going on?

The Web IDE sometimes needs some incentive to update the info - e.g. flash a dummy sketch OTA.

But if you already flash via cable I’d rather use this command in DFU Mode

particle update
particle flash --usb firmware.bin

But make sure you’ve got the most recent version (currently 1.21.0)