Can reflash Tinker, but no response from Tinker on any command

This used to work, but not now. Able to flash tinker from laptop. Able to reflash tinker from Android phone. Ran tinker on phone. Connected thru wifi OK. Tried any digital read or analog read - used to get a readback, now the button is circled in bright colour and nothing happens. Tinker appears to hang.
Reloaded firmware using dfu and usb. That loaded OK and core got to breathing cyan. Reflashed tinker. no error, but no readback on phone. Able to flash blinking LED from laptop - that ran OK. Reflashed tinker again.No readback.
Frustrated of Edinburgh.

Hi @gotopcs,

Can you see your core in your cores list when you login to the build IDE? spark.io/build Just as a sanity check, sometimes people mis-type their email address on their mobile device, and cores sometimes end up claimed to one account, while you’re logged into another typo’ed account.

Thanks,
David

Yes I can see the core (name), and can flash e.g. blinking led which runs fine.

Same as what Dave said, could you try logging out/in on your phone to make sure there isn’t a mistake on that end?
This might be helpful as well: http://suda.github.io/spark-web-interface/ If you log in there using your Spark credentials, it’ll show you all the exposed functions/variables. That way you can check whether or not Tinker is running the way it should. That might help narrow it down.


@Dave Can we somehow add that Github to the resources, it’s actually really useful! @suda, Would you mind that?
Original post: https://community.spark.io/t/spark-core-web-interface-works-on-desktop-mobile/5908

Thanks for your comments and suggestions. I’ve switched the phone off and on to make sure the app stopped properly, but on restart, just the same. No readback. I’ve tapped on the wifi symbol at the top (of tinker) and logged in several times with the correct password, then hit Connect. The Core changes from breathing Cyan to flashing cyan, green briefly, then cyan again. The phone reports No Cores found! Hit “Try again”. Flashing stopped, breathing resumed. Again, “No cores found”.
I’ve tried uninstalling spark then re-installing it on the phone. Same result.

Thanks for the link to github, Moors7. Those routines work OK! Can read back stuff from dig and analog ports, so the problem seems to be with the phone connection.

1 Like

I was referring to logging out your account from the app. Using the WiFi symbol is simply to let you add your cores to the network. It could be that you logged in on your phone with a typo’ed account, which could cause problems like Dave mentioned. To log out you should use the Cog symbol. To be sure, you could always reinstall the app. But lets first try logging out/in.

1 Like

I don’t have a Cog symbol! At the top RHS of the Tinker panel, I have a pencil symbol which allows me to change the name of the core (this works!) and the wifi symbol next which allows addition of cores. The menu at the bottom left (Galaxy S4) allows clearing tinker (works), reflashing tinker (works), log out (works) and Help which takes me to the Spark “Getting started” web page.
It’s all very strange.
I can read back data from my core using wifi and the suda/github web page. This is great, but I’d like to do better - is there a freely available script somewhere which I could customise and use on my browser to do the readback?

Sorry about the cog stuff, I’ve got an iOS device and thought it’d be the same. Logging out of the app should normally suffice to make sure you haven’t made any typos. Reinstalling it should also work.
The tutorial section contains quite a few examples of making web-based interaction with your cores. You should definitely check that out. Tinker is great for testing purposes, and to get started, but after that, you’ll want to design your own stuff anyway. You can use functions, variables, Server Sent Events, and perhaps a DHCP/UPD server (?). Plenty to choose from :smiley: