Build didn't produce Error: Comma

Whenever I try to flash with Particle dev I get the error “Build didn’t produce Error: Comma…” I have a breathing cyan but cannot reflash since my last sketch. Plus my tinker app shows my device as offline. Any ideas?

After a factory reset and trying to reconnect with app I get an error that reads.


“Setup process couldn’t disconnect from the Particle device Wi-fi network. This is an internal problem with the device, so please try running setup again after restarting your Particle device and putting it back into listening mode (blinking mode LED) if needed.” Obviously, I’ve done that with no results.

You can try flashing the basic Blink program on the Web IDE first, waiting at least 10 mins for it to update your firmware to the latest version.

That worked for me.

Be patient while the LED goes through its machinations.

1 Like

Alternatively, use the CLi with particle update when it’s connected and in DFU mode. That’s a lot quicker, and less prone to failure.

I ran particle update and its been breathing magenta for about 10 min now.

I get it back connected and then when I try to flash again same error with Particle dev and web IDE puts it in breathing magenta indefinitely. I can however tinker the D7 LED with my phone. Are IDE’s down?