"build couldn't produce binary Error Command . . ."

Firstly, hello Particle community! I just recently received a Photon and have started playing with it. I prefer the offline Dev (there’s just something about an editor that is “Stand-alone” versus one I have to visit in a browser, even if the code still compiles in the cloud), and have been quite happy with it the last few days. I have recently had to switch to the online build.particle.io, however, because my Particle Dev is throwing this error when trying to compile my .ino file:

build couldn’t produce binary Error Command . . .

It throws no errors, and I have checked and double checked the very simple code in Arduino software, so I know that isn’t the issue. Having looked around at some other posts, I am worried this may be a result of my errant deletion of a .ds_store file. I recently bought a Mac, and not being familiar with the files types native to Mac OS X and consequences of deleting them, I chucked a .ds_store file or two and never thought twice about it… Until my Dev crapped out on me. I’m tech saavy, but I’m not highly familiar with the .ds_store file or what it does, so I don’t know if this is truly the cause and whether I can/should build another.

I may be 100% off on my guess work, so if there’s any other causes you could think of, please feel free to bring it to my attention. Thanks in advance!

I get this error from time to time on my Mac with Particle Dev…

A couple things to look at, firstly trying a close Particle Dev and reopen or even restart your machine

1: are you sure you have the library files in the same directory as the .ino file?
2: are you sure you can write to that directory? (I ran across this using Google Drive and had set read only)
3: make sure there are no other files in the directory you wish to compile alongside your .ino file.

try those things and see if you can compile…

even doing all of the above, I will get the error from time to time… I usually restart Dev and it works

Thanks for the quick reply! When you say libraries, you’re meaning the ones I use in the sketch, right? It’s pretty basic for the time being and I’m not importing any libraries. I have it nested in a Documents/Programming/Particle/ProjectFolder type deal because I’m particular, but other than that it is in a folder completely to itself.

As for the restart fix, that was the first thing I tried. I even went so far as uninstalling and reinstalling the Dev. I’m in a little over my head with the Mac OS here, so there’s a good chance I’m doing something silly and just don’t realize it.

I’m not a Mac user myself, but a few other tips
Try to rather open the project folder than only a particular file in it.
Especially look again (as @BulldogLowell said) in your project folder not to have any other files in there than one single .INO file and (if needed) .H/.CPP files (are allowed even if not used in your project).
Even avoid sub-folders.
You actually can have other files and folders in there, but then you must provide a particle.ignore file that contains all file/folder names (one per line) other than the ones mentioned above (including .ds_store and other hidden files).
Also make sure to have your target device selected.

Hey! Sorry for the delay in response. I’ve been out of state and working hard. I again looked over my folder containing the .INO file, and it is empty apart from that file. I took ScruffR’s advice and tried opening the project file (previously, I had been opening the .INO directly), but still no dice. For now, I guess I’ll try to just use the online build.particle.io, but I am pretty frustrated at not having access to the Particle Dev. Let me know if you think of something else and I’ll give it a shot.

Okay, now build.particle.io is crapping out on me. I switched over to Particle Dev in desperation, and it worked for the “Check and Compile” step. I picked my device, selected flash, and got the following trace back:

/Applications/Particle Dev.app/Contents/Resources/app.asar/node_modules/spark-dev/node_modules/when/lib/decorators/unhandledRejection.js:80
Hide Stack Trace
TypeError: Cannot read property ‘toString’ of undefined
at Object.parseString (/Applications/Particle Dev.app/Contents/Resources/app.asar/node_modules/spark-dev/node_modules/gcc-output-parser/lib/main.js:6:18)
at /Applications/Particle Dev.app/Contents/Resources/app.asar/node_modules/spark-dev/lib/spark-dev.js:761:38
at tryCatchReject (/Applications/Particle Dev.app/Contents/Resources/app.asar/node_modules/spark-dev/node_modules/when/lib/makePromise.js:845:30)
at runContinuation1 (/Applications/Particle Dev.app/Contents/Resources/app.asar/node_modules/spark-dev/node_modules/when/lib/makePromise.js:804:4)
at Fulfilled.when (/Applications/Particle Dev.app/Contents/Resources/app.asar/node_modules/spark-dev/node_modules/when/lib/makePromise.js:592:4)
at Pending.run (/Applications/Particle Dev.app/Contents/Resources/app.asar/node_modules/spark-dev/node_modules/when/lib/makePromise.js:483:13)
at Scheduler._drain (/Applications/Particle Dev.app/Contents/Resources/app.asar/node_modules/spark-dev/node_modules/when/lib/Scheduler.js:62:19)
at Scheduler.drain (/Applications/Particle Dev.app/Contents/Resources/app.asar/node_modules/spark-dev/node_modules/when/lib/Scheduler.js:27:9)
at doNTCallback0 (node.js:416:9)
at process._tickCallback (node.js:345:13)

It suggested that I update the Atom package, so I’ll try that and see how it goes. Any further ideas are still much appreciated.

Also, new symptom: in Dev, the .ino will compile with no device is selected. When the device is selected to allow flashing, the above error message is displayed.