Breathing cyan LED but can't connect via iOS app or API [SOLVED]

Just received my Spark Core and having trouble connecting :frowning:

I’ve tried:

  • Connecting in the iOS app
  • Factory resetting 10+ times
  • Reloading the firmware from GitHub
  • Powering the Spark via USB on my Mac and via a USB wall charger
  • Saving the SSID & WPA key in a serial console

I have a breathing cyan LED but I can neither connect in the iOS app, nor get a response when cURLing the Spark Core after manually claiming it in the web interface.

I have no idea what else to try - any ideas?

Running a Technicolor TG582n, 802.11n 2.4GHz with b/g compatibility enabled. No firewall afaik.

Sounds like you’re on the right track @jongold. If you have breathing cyan, then the Core is connected to the Spark Cloud, so that part’s taken care of.

Next step is to make sure you have claimed the Core. Is a Core listed in the web IDE? Does the Core ID listed in the web IDE match the one reported via USB when hitting the i key?

If you have it connected and claimed, then the iOS app should reload your list of Cores when it (the iOS app) starts up—try making sure it’s stopped running by double tapping the button on your iPhone and long pressing on the Spark app until the remove badge appears.

If you’re not getting any response with curl, then something about your request must be bad. What does your curl command look like?

Thanks for such a quick reply :smile:

I brought it into work today to try on another wireless network - still couldn’t connect with the iOS app and it wouldn’t connect after entering my wifi details in the serial console; but after a couple of factory resets I finally got it to connect & claimed it again in the web IDE.

From there, the iOS app was still asking me for wifi details but after a couple of failures it displayed a ‘back to tinker’ button which—finally—let me connect to the device & play with the ports. curl works too now.

I’ll mark that as a success for now (at least until I try it again at home this evening) - not sure exactly what I did to fix it, but hey, it works! Will track down another router to try at home to see if I can narrow down the problem.

Thanks for your help!

@jongold - glad you made it to Tinker-land. Ping us again if you run into any more issues going forward.


I have the same technicolor router. I am facing the same issues. The core wont get past flashing green. Im using ios with a mac connected via USB. I have even tried without a WEP. Im at a loss and it is driving me crazy. I have tried everything over the past 4 days. it wont connect. Please help!