Breathing Cyan but could not connect using Tinker and USB [Solved]

I bought a kickstart core and at first time it works normally using tinker and web IDE. Recently I tried to use it again in another wifi network and it show solid magenta. Reading the topics, I recover the firmware using CC3000, deep update , factory, tinker app using DFU-utils.

When I tried to connect throught tinker the leds complete the connection giving a breathing cyan but tinker could not connect with core. I also tried CLI but the serial port could not be find. I can see the core listed in COM6 when it is in listening or DFU mode but I can interact with it using another SW like Putty. It gives me the message like the serial port could not be opened.

Could someone please give some ideas to what to do?

Thanks in advance

One thought:
If I understand your first paragraph right, you’ve had the Core hanging around for a longish time?
Was it about half a year since you last tinkered with it?

If so, your Access Token might have expired - then you’ll find topics dealing with that.

I can’t quite understand what you want to say with this - :confused:

@ScruffR thanks for your answer.

The core was working and I don´t remember the last time I using it. Recently I´m trying to connect with it using another wifi network.

I saw in the topic how to get another token. I´m sending the command: and i receive the answer:

  "ok": false,
  "error": "Not Found",
  "device_name": "mutant banjo hacker hacker turkey"

Related to item that you didn´t understand what I mean is that I can connect to the core using USB also. The serial port related to USB could not be opened by Spark Dev or other software like Putty.

Any comments about that?



Hi @marcoascarvalho

The command in the doc is a curl command, not something you type into a web browser.

Curl is a command line program available for almost any platform that lets you do web request similar to how a browser does then but (and this is the important part) with more control.

Have you installed curl? Can you try the command using curl on the command line?

1 Like

It’s again a bit confusing. You can connect via USB but you cannot get it to work, so you actually can’t connect - you only plug it in :wink:

However, if we knew what your system is, we could help more targeted to your problem.
But I just assume you’re on Windows, so you might be missing the needed drivers.
Have a read in the docs “Get connected”, “First Steps” and “Troubleshooting”.

Hello @bko.

Thanks for your answer.

I didn´t know about curl. I installed it now and the command: curl -k
give the following result:

    "token": "xxxxx",
    "expires_at": "2014-02-28T15:02:26.217Z",
    "client": "user"
    "token": "xxxx",
    "expires_at": "2015-07-02T13:27:28.547Z",
    "client": "__PASSWORD_ONLY__"
    "token": "xxxx",
    "expires_at": "2015-07-02T13:36:14.384Z",
    "client": "__PASSWORD_ONLY__"
    "token": "xxxx",
    "expires_at": "2015-07-03T21:47:25.331Z",
    "client": "spark-ide"
    "token": "xxxx",
    "expires_at": "2015-07-11T23:48:26.226Z",
    "client": "spark-cli"
    "token": "xxx",
    "expires_at": "2015-07-12T00:29:09.659Z",
    "client": "__PASSWORD_ONLY__"
    "token": "xxxx",
    "expires_at": "2015-07-16T01:20:47.875Z",
    "client": "spark-cli"
    "token": "xxxxxx",
    "expires_at": "2015-07-16T02:42:32.124Z",
    "client": "__PASSWORD_ONLY__"
    "token": "xxxx",
    "expires_at": "2015-07-18T17:16:42.327Z",
    "client": "__PASSWORD_ONLY__"
    "token": "xxxx",
    "expires_at": "2019-12-31T23:59:59.753Z",
    "client": "__PASSWORD_ONLY__"

I extend the expiration date until 2020.

Sorry for the confusion again . My mistake . I wanted to say that i can not access the core through USB although I have listed in the device manager the COM6 that’s pointing to the core ( Core Spark with Wifi and Compatibility Arduino ) .

I tried to config the core using the Spark CLI command spark setup but it can not find my core at the serial port . I installed the windows drivers. It gives me the following messages:

Finding your core id
Press and hold the MODE button until your core blinks solid blue
 - Is your core blinking blue?  Then press ENTER - Potentially unhandled rejecti
on [2] Timed out (WARNING: non-Error used)
I didn't find any cores available via serial
Serial err: Error: Opening \\.\COM6: File not found
Serial problems, please reconnect the core.
Something went wrong Serial problems, please reconnect the core.
Press and hold the MODE button until your core blinks solid blue
 - Is your core blinking blue?  Then press ENTER - Potentially unhandled rejecti
on [4] Serial problems, please reconnect the core. (WARNING: non-Error used)
Potentially unhandled rejection [5] Error: Serialport not open.
    at SerialPortFactory.SerialPort.close (C:\Users\Marco\AppData\Roaming\npm\no
    at C:\Users\Marco\AppData\Roaming\npm\node_modules\spark-cli\commands\Serial
    at runSideEffect (C:\Users\Marco\AppData\Roaming\npm\node_modules\spark-cli\
    at C:\Users\Marco\AppData\Roaming\npm\node_modules\spark-cli\node_modules\wh
    at tryCatchReject (C:\Users\Marco\AppData\Roaming\npm\node_modules\spark-cli
    at runContinuation1 (C:\Users\Marco\AppData\Roaming\npm\node_modules\spark-c
    at Rejected.when (C:\Users\Marco\AppData\Roaming\npm\node_modules\spark-cli\
    at (C:\Users\Marco\AppData\Roaming\npm\node_modules\spark-cli\no
    at Scheduler._drain (C:\Users\Marco\AppData\Roaming\npm\node_modules\spark-c
    at Scheduler.drain (C:\Users\Marco\AppData\Roaming\npm\node_modules\spark-cl
Potentially unhandled rejection [7] Serial problems, please reconnect the core.
(WARNING: non-Error used)*

I will continue to search for a solution in the forum topics but I will be very grateful if you or someone else could continue to help me.



Just to reiterate, have you read this and installed all the tools and drivers?

For serial


1 Like

Today I find the problem. I reboot my PC and after that it recognize the Spark core serial port. Maybe when it enter in DFU mode the PC serial port was stucked by some other software that probably was opened like spark IDE.

The other problem is a huge head problem. I forgot that I was using another email account to access Spark Core. When I was using the CLI it gives the message:

Failed to claim core, server said [ ‘That belongs to someone else. To request a transfer add ?request_transfer=true to the URL.’ ]

I sent an email to that identify that I was using a new account to access Spark core. So I changed the email and reset password. After that the core is working normally.

Thanks @ScruffR and @bko to try to help me.


Can I mark this as [Solved] then?

Yes, please.