Core refusing to connect to serial or USB [Solved]

I’ve got a :spark: Core which is misbehaving… I can’t get it to do anything with the USB serial.

I’ve plugged it into various machines, used different cables, tried Windows and Linux - and it just won’t show up (either a a COM in Device Manager in Windows, or as /dev/ttyACM0 or /dev/ttyUSB0 or in dmesg in Linux).

It successfully draws power from the USB through.

Any ideas?

I’ve tried clearing memory and factory reset. It connects to the WiFi fine, and I can reflash it from the Web IDE. I first noticed the issue when I wanted to use Serial.begin() in a app - but now I’ve realised it might be a wider issue.

Assuming your hardware is working, the USB serial port is non-existent until Serial.begin(9600) is called (or whatever baud rate you want)… I assume you are calling that from setup()?

1 Like

The best way would be to put the core in DFU mode (aka blinking yellow)

It should then show up in the Serial list.

Otherwise, like what @Raldus mentioned, you need to initialize/open a Serial port using Serial.begin in Setup()

I think the stock Tinker firmware will show up as a serial device when in ‘listening mode’ (blinking blue).

For Windows you’ll need a driver: http://docs.spark.io/#/connect/connecting-your-core-connect-over-usb

For Linux it depends on your system, could be a /dev/ttyACM*, could be a /dev/cuaU*, or a /dev/usbmodem*, etc.

Thanks!
David

It wasn’t stated, but I’m guessing you have other Core’s that do connect via USB?

It was a problem with the Core itself. After several hard factory resets it finally came back to life!

2 Likes

Would have been nice to know the exact problem…

One reset should be the same as multiple resets. If it’s taking more than one, you might have a hardware problem.